|

Firmware for ABV387PRO

I have a ABV387PRO board. It is having calibrating issues on a Windows 10 system. Software/drivers have been updated. To rule out that the board itself is failing, I would like to upgrade the firmware.

Can you please send this file my way? 

Best Answer

«13

Answers

  • elongelong Posts: 1
    Craig:
    Could you send this to me as well?  I am troubleshooting a ABV387S300 board that is spiking as well and want to try the firmware to rule out a failing board too.
    Thanks,
  • carawade1carawade1 Posts: 1
    I am having the same issue with several of the machines within our elementary building.   We're running OS 10.11.6.  I would also like to try the new firmware.  Please email me.  Thanks!
  • Adam K PrometheanAdam K Promethean Posts: 1,709 admin
    Hi @carawade1

    I will send you an email which you will receive shortly.

    Thanks,
    Adam
    Promethean Technical Support
  • DmnorrisDmnorris Posts: 2
    I am having problems with pens not working on 2 ABV3785 since the new Activinspire 2.86693 update.  I have updated the Activdriver to 5.14.21. I am running OS 10.11. I would like to try the new firmware. 
    Please email me. Thanks!
  • Hello Dmnorris,

    Can I please ask what issues you are having with the ActivPen? Is there no calibration or interaction. We don't want to update the firmware if not necessary.

    Thank you,

    Craig  
  • Hello,
    I noticed that some of our Promethean boards ABV387PRO have different firmware.
    Could you please send me the firmware too? 
    Thanks
  • Hi Michelebelotti,

    I have sent you an email with the latest firmware available for the 387Pro ActivBoard.

    If we can be of any further assistance please do not hesitate to get back in touch.

    Kind Regards,
    Paul

    Promethean Technical Support
  • sjcastellosjcastello Posts: 3

    Hello,

    I am providing support to a teacher with an ABV387pro experiencing the same problems and pens are unusable at this point. Have calibrated, updated Drivers and ActivInspire, replaced pens, checked cables. Firmware is last thing to try before replacing equipment. Currently on 8.04 Build 4 with no updates available.

    Please, if you could, email me the file as well. Thank you.

  • Adam K PrometheanAdam K Promethean Posts: 1,709 admin
    Hi @sjcastello

    I'll send you an email with the upgraded V8.09 firmware which is for the ActivBoard 387PRO.

    Kind regards,
    Adam
    Promethean Technical Support
  • DionDion Posts: 1
    Hello,

    We are experiencing some connectivity issues with a couple of laptops. We'd like to receive the latest firmware for our ActivBoard 387PRO boards.
  • Hello Dion,

    Thank you for your post.

    I will send you an email with the firmware file.

    Thank you,

    Craig 
  • AlexS93AlexS93 Posts: 1
    Hi

    We are also experiencing some issues with our ActivBoard 387PRO's running firmware version 8.04 Build 4

    Please can you email me the latest firmware available thanks, we have several of these boards throughout our school.

    Thanks
    Alex
  • Adam K PrometheanAdam K Promethean Posts: 1,709 admin
    Hi AlexS93,

    I've sent an email to you directly with the firmware information.

    I hope this helps.

    Kind regards,
    Adam
    Promethean Technical Support
  • rabahatmanirabahatmani Posts: 1
    Hi ,

    can we have the firmware update
  • Adam K PrometheanAdam K Promethean Posts: 1,709 admin
    Hi rabahatmani,

    Thank you for your post.

    I've sent an email directly with this firmware file and instructions.
    I hope this helps,

    Kind regards,
    Adam
    Promethean Technical Support
  • HI Adam,
    I'm working on updating our boards to the latest firmware. We are running Mac's with OSX 10.11.5 and above. They are all experiencing issues with the pens being able to be used throughout the day. I've tried all steps in previous threads before updating the firmware.  I'm upgrading from V8.04 Build 4 to V8.10 build 7. However, I've run across a few that continue to fail to update even after restarting a few times and making sure the drivers are up to date. Could you send me older firmware, perhaps ones after V8.04 build 4, to try? 

    Thanks!
  • Hi stephenssensei,
    Thanks for posting.

    The only firmware released after V8.04 was version 8.10.

    If this is happening on all of your ActivBoards, this could be in relation to the cables/computers being used. 
    What is the exact issue you are experiencing?
    If you log on with a local admin account, does the same issue happen?
    Have you tried to calibrate the ActivBoard since the firmware upgrade was applied? If not, please calibrate and see if this helps.

    You've mentioned that the drivers are up to date, please could you confirm the version you are using? This can be found by clicking on the ActivManager icon and selecting Control Panel. The driver will be listed at the bottom of this window.

    Thanks,
    Adam
    Promethean Technical Support
  • Hi Adam, 
    I've definitely checked cables to and from boards. The problem seems to be when teachers run Chrome. The pens stop working. After a firmware update they are better and no longer quit working after starting Chrome. I'm just having trouble installing the update on a few computers even after I logged in as the Admin in the computer. 

    The driver is 5.14.21.

    Any other suggestions? 

    Thanks!
  • Could you send me an updated Firmware for ABV387PRO.  Same issue as everyone else, Chrome kills the pens. Running V8.04 Build 4.  
  • Hi stephenssenseitiffanyg,

    Thanks for posting.

    I'll send you both emails with this information.

    Kind regards,
    Adam
    Promethean Technical Support
  • Please send me the Firmware also. We have begun to have the same issue on our elementary campus as well. We are running Windows 10 on a ABV387Pro boards. 
  • rmartinrmartin Posts: 2
    edited on January 20 2017
    I am having the same issues as the others.  Windows 10, uninstalled and re-installed (with most current activdriver), still cannot calibrate.  Pen responds on the board but needs to be calibrated badly.  Light flashes a color change to blue when I touch the calibration screen but does not calibrate.  Would like to upgrade the firmware.
  • Hi rmartinawgrace,

    Thanks for posting.

    I will send you a firmware file with instructions and hopefully this will help with the issues you are experiencing.

    Kind regards,
    Adam
    Promethean Technical Support


  • Hi Adam,

    I did the Firmware update as specified and am still having issues with the pen not responding correctly. It did seem to work a little better, but still spiking and skipping. Do you think it could now be the AC3 Electronics going bad.  HELP 
  • Adam, thank you for sending the firmware.  I installed the firmware as well and am still having the issue of not calibrating.  Light still changes to blue when I hover over it and the calibration screen pops up but will not respond to the pen.  The computer itself recognizes the pen, it just needs to be calibrated (which I cannot do successfully).  Running Windows 10 and the board is the ABV387.  Any other ideas on what I should do?  I had previously, unplugged, uninstalled, rebooted and re-installed the driver and software.  Have checked the Device Manager and all is well.  Activinspire is up to date.  Even tried closing Chrome as I saw the previous posts about Chrome causing issues.
  • Hi awgrace,

    I will reply back to your email.

    Thanks,
    Adam
    Promethean Technical Support
  • Hi rmartin,

    Thanks for your reply.

    I'll send you an email direct so we can troubleshoot this issue further.

    Kind regards,
    Adam
    Promethean Technical Support
  • fossejfossej Posts: 6
    Losing connection to a ABV378PRO board, and digital ink skips daily.
    Mac OS X 9.5.5
    ActivDriver 5.4.21
    ActivInspire Version: 2.8.66693
    Firmware Version: ActivBoard V8.04 Build 4
    Would like to update the firmware in hopes of fixing issues. Thanks.
  • Hi fossej,

    Thank you for posting.

    I have responded to your separate post you have posted on the link below:
    https://community.prometheanworld.com/en/discussion/7001565/losing-connection-to-a-abv378pro-board-updated-firmware-available#latest

    Thanks,
    Adam
    Promethean Technical Support
«13
Sign In or Register to comment.