2 PRM-10 projectors not working

kenjancefkenjancef Posts: 2
We have 2 PRM-10 projectors in our district (out of warranty, of course) that are not working. When plugged in, the red POWER light turns on, but that's it. Nothing happens when I hit the power button on the remote. I tried replacing lamps from known working projectors, and still the same thing. I also tested this remote with another PRM-10 and it works fine.

So what is the cause of the power light being solid red but not being able to turn on? Any help would be GREATLY appreciated! :)

Answers

  • Hello kenjancef,

    This model of projector has 2 remote codes that it can use. If the code on the projector was changed through the menu, it may not work with the remote. 

    To switch the code on the remote, press the "menu" and "image" buttons and hold for about 5-10 seconds.

    Press the power button on the remote again to see if it is now working.

    Thanks
    Michael
    Promethean Support
  • kenjancefkenjancef Posts: 2
    Wow... amazingly that worked! So... why would this all-of-a-sudden change? The projectors were working fine, then they didn't... I can't see how this would change, unless the teachers did something with the remote that they didn't realize?
  • Jarrad PrometheanJarrad Promethean Posts: 392 mod
    It is possible that, when attempting to adjust other settings in the Projectors' menus, that the remote code setting was accidentally changed.

    In the case of the PRM-10 and 20 Projectors, there are only two settings to toggle between for the communications with the Remote; if the setting is accidentally changed in the Projector, then holding the MENU and IMAGE buttons on the remote for about 15 seconds will change a similar setting within in the remote.
Sign In or Register to comment.