ActivHub not being recognized

I haven't used my ActivHub all school year but it worked last year.  When I plug it in, it says Windows cannot recognize the USB.  I just downloaded the recent versions of ActivInspire and ActivDriver.  

The USB shows a solid red light.

Please advise on how I am to get this working so that I can use ActivSlate!


  • Hi kaparrish,

    Thank you for posting to the Support Community.

    When plugged in and getting a connection, the ActivHub will flash green. When it is flashing red, there is a communication issue. Is there another USB port on your computer that you can try plugging the ActivHub into? 

    You may also want to test to see if this ActivHub is working on another computer. If it works on another computer, there is something on your computer that is causing a miscommunication. You will want to look into your Device Manager (if on a Windows computer). If you see a device under HID or USB with a yellow exclamation mark, you can resolve the error by manually updating the device driver. Follow the instructions below to do so.

    • Right click on the device and select Update Driver Software.
    • This will run the Update wizard. Select Browse my computer for driver software. Windows XP users will need to select No, not this time and Install from a list or specific location.
    • Copy and paste this file path C:\Program Files\Activ Software\ActivDriver\activusb\XP into the search box. This path is valid for all versions of Windows. Alternatively, click Browse and navigate to this location.
    • Click Next to begin the update.
    • Once complete, the ActivHub will be detected by the computer and the ActivHub will be flashing green

    Alternatively, you can try connecting another know working ActivHub to your computer and see if that one connects. If it connects, then your ActivHub could be faulty.

    Thank you,
    Promethean Technical Support
  • C:\Program Files\Activ Software\ActivDriver\activusb\XP

    I typed that into the search box and it said it could not be found.
  • Can you confirm for us which version of ActivDriver is installed on the computer that the Hub is plugged into?  Article 1012 can help you locate that information on the computer.

    Are you able to navigate to C:\Program Files\Activ Software\ActivDriver\activusb\XP using Windows' File Explorer?

    If that hub is plugged into a different computer which has our Driver installed, does the same error message appear?

  • I navigated to that location and it says the most current driver is already installed.  I have not yet had the opportunity to check a different computer.
  • If you need our updated 5.17 ActivDriver, that can be downloaded from our ActivDriver Page on our Support Site.

    Is the Hub being plugged directly into a USB port on the computer in use or is there any additional hardware like a docking station or extension cable used to facilitate that connection?   If the latter is the case, please try plugging the Hub directly into one of the USB ports on the computer.
  • I tried to download the ActivDriver again even though I had just installed it Monday and it gave me the option to repair.  I chose to repair and then it gave me a fatal error: 0x80070643.

    So, I uninstalled the driver so that I can reinstall it.  After installing it, it came up again where I need to repair the driver!
  • Hi, kaparrish. To try to resolve the 0X80070643 error, you may use this article for assistance.

    Were you able to test the ActivHub on another computer?

    Best Regards,
  • I did test it and it keeps giving me an error about the driver being installed.
  • Hi kaparrish,

    Did the ActivHub work on another computer which had the ActivDriver installed?

    I would recommend to manually uninstall the ActivDriver, please follow the instructions on this article.

    Once uninstalled, it is important that the computer is restarted.

    Ensure that the ActivHub is not connected to the computer and download a new ActivDriver installer just in case the previous had been corrupted.
    This can be downloaded from here.

    Kind regards,
    Promethean Technical Support
Sign In or Register to comment.