Accessoriesactivexpression and self paced
#4132
Anonymous
Inactive

Further to Jon’s point, Not only should the ActivInspire software and ActivDriver be at their latest versions (The installer for both is downloadable from Promethean Planet here), but the Firmware for the ActivExpression devices and the ActivHub need to be at their latest as well.  Article 10421 from our Knowledge Base will advise you on how to update the firmware on those devices.

(Support Case 00485876)