Accessoriesactivexpression and self paced
#4131
Anonymous
Inactive

Pamela,
It may be that your firmware on your hub and your handsets need upgrading to support self paced questions.
And/or It may be you are running an old version on ActivInspire? (Try at least v1.8)
I’m not a Promethean Tech Support agent. But I do a lot of training on the handsets throughout the UK.
Hope this helps?