Interactive Flat PanelsDual Pen
#4365
Anonymous
Inactive

Chris,

Thanks for posting. I’ve logged this question against case 494186.

What kind of board do you have? Can you provide us the model number? Does the board appear in Activmanager, and what is its current firmware version? What is the version of the Activdriver and Activinspire?

Dual user requires a couple of things to work correctly; it requires a compatible board with the appropriate firmware version to be connected and detected by Activinspire, and for Inspire to be above a certain version (1.4, if I’m not mistaken).

So, to answer your question directly, if your board requires a firmware update, you’d need first to purchase the Activarena upgrade for the board and then would have a disc containing the firmware. You can upgrade the firmware using the directions in article 10800 and the files on the disc. Many of our boards do not require a firmware upgrade for this to work. Naturally, you can download the latest version of Activinspire from our website.

However, many users encounter an error message reading “Dual User requires an update available for Promethean Activboards only,” despite having a board connected to their computer. Possible reasons for this are that the firmware is not up to date, that the board is not compatible with this feature, that the driver is not up to date with the software, and that the board is either not connected or not detected by the computer. The questions above should help us identify these potential pitfalls.

Thank you,
Daniel Barnwell
Promethean Technical Support