Interactive Whiteboards
Viewing 4 reply threads
  • Author
    Posts
    • #1476
      dabip001dabip001
      Participant

      We have 24 new (since Jan, 2016) 70″ Activ Panel Promethean boards but all remotes are AWFUL.  Users must point DIRECTLY at the switch panel area of the board and must be within about 10′ for them to work.  THEN when user touches Source nothing happens.  Hit Source again and it’ll flash on and off.  Hit it a third or fourth time and finally user can select a source.  ANY hope that firmware or ANYTHING might be done to make remotes on brand new $5000+ boards work properly?

    • #7675
      Anonymous
      Inactive

      Hi,

      Thanks for posting on the Support Community.

      I’ll contact you directly regarding these issues raised.

      Kind regards,
      Adam
      Promethean Technical Support

    • #7676
      Anonymous
      Inactive

      I was sent a replacement remote control; it works better.

    • #7677
      Anonymous
      Inactive

      Although the failed remote was replaced we continue to struggle with very sluggish, intermittent response from the 70″ Activ Panels – both using remote controls and using the built-in panels.  Hit Source and nothing happens.  Hold down source on the panel and nothing happens.  Keep hitting source and, after 30 seconds to 1 minute the source screen flashes one and off again.  Hit source again and it flashes again.  On the 3rd or 4th try eventually the source menu will appear and STAY on the screen.
      If I had a flatscreen at home that worked like this it’d be back in the store overnight.

    • #7678
      Anonymous
      Inactive

      Hi,

      Thanks for the update.

      I’ll contact you directly regarding this issue so we can further look into this.

      Kind regards,
      Adam
      Promethean Technical Support

Viewing 4 reply threads
  • You must be logged in to reply to this topic.