Software Solutions
Viewing 4 reply threads
  • Author
    Posts
    • #34412
      henriksenhenriksen
      Participant

      Hi,

      I have a couple of issues going on with one of the Promethean boards in our district.

      First, it seems like the Activinspire freezes up at the load screen where the flame lights up and this seems to happen on version 2.21 and 2.22.

      Second, the USB cable detects the Activdriver from the board to laptop, but when I try to calibrate any pens, the calibration screen takes forever to show up or be detected on the board or screen of the laptop. When I try a pen (which I have done several times with a variety of old and new pens) none of them seem to work or detect when the calibration screen does show up. I’m looking for a possible firmware update on a ABV387E100. I’m currently have the newest ActivDriver installed – v5.18.19.

      Any suggestions or tips would be greatly appreciated.

      Thanks,

      Chris

    • #34414

      Hello Henriksen,

      Thank you for your post.

      We would like you to try performing a manual uninstall and re-install. Prior to doing so, it is important for you to obtain your activation key by following the article posted below.

      1084

      After obtaining the key, please follow the instructions in the article below.

      Windows – https://support.prometheanworld.com/article/1644/

      Mac OS – https://support.prometheanworld.com/article/1646/

      Kindly provide us with the version of operating system that you are running, and which firmware version your ActivBoard is running. To find the firmware version, please see the article below.

      1584

      We look forward to assisting you further in this matter.

      Kind regards,

      Jordan

      Promethean Technical Support

    • #34415
      henriksenhenriksen
      Participant

      Hi,

      We are currently using Windows 10 version 21H1. The firmware that is currently on that board is V8.04 Build 4 USB; driver version V 5.8.46.3.

      Thanks,

      Chris

    • #34418

      Hello Chris,

      Thank you for your post.

      You will need to update the ActivBoard 100 Series from V8.04 Build 4, to V8.10 Build 7, and then to V8.12 Build 2 (HID). The HID firmware is necessary for Windows 10 past the 1903 build. However, you must be on firmware version 8.10 to upgrade to the Human Interface Device (HID) firmware as it is a prerequisite.

      To upgrade from 8.04 to 8.10, please ensure that you are directly connected to the ActivBoard with a cable less than 9 feet (3 meters) in length and that you are bypassing any wall boxes/wallplates/extenders/boosters. We have included a link below that walks you through this process.

      1038

      In regards to the driver version that you are on (5.18.19) that is the correct version for Windows 10 post 1903 and the 100 series ActivBoard.

      We hope that this helps.

      Kind regards,

      Jordan

      Promethean Technical Support

    • #34441
      henriksenhenriksen
      Participant

      Thanks. I will give that a shot. The driver version I currently have installed is 5.18.19 on a Windows 10 machine. I’ll update the firmware and let me know what happens.

Viewing 4 reply threads
  • The forum ‘Software Solutions’ is closed to new topics and replies.