Student Response Devices
Viewing 1 reply thread
  • Author
    Posts
    • #19450
      Elaine GleatonElaine Gleaton
      Participant

      Hi – I am using attempting to use my school’s ActivSlate with my home computer, a Mac, with the latest updates (Catalina.). I haven’t tried using the ActivSlate with this computer before, just on school PCs.  I did download the latest driver, hoping that the problem I’m having would go away.  It did not.

      Once ActivInspire is opened, the pen moves the mouse around, but I can’t click or activate anything.  No ability to draw 🙁 which was the main reason I wanted to use it.

      As I was writing this, I tried it on my husband’s PC – installed ActivInspire and the ActivSlate driver.  Works great!  Which would be fine but I really want to be able to use my own computer.

      Thoughts on what I need to do to get this working on my Mac?  Thanks in advance :).

    • #19454
      Wendy PrometheanWendy
      Moderator

      Hi Elaine,

      Thank you for your post.

      Can you confirm which ActivSlate you are using?

      There should be a product code on the bottom.

      Also, what is the OS Version of your Mac and which ActivDriver is installed on your husband’s Windows PC?

      You may need to use an older driver for this to work on Mac, try to uninstall ActivDriver only (not Inspire) and installing this version instead:

      https://promethean.box.com/s/i3d5ganc3hlo1qaasa231wuuhfomab5r

      Please do not hesitate to get back to us r if you have any questions, we’d be happy to help.

      Thank you,

      Kind regards,

       

      Wendy

      Promethean Technical Support

      home

       

Viewing 1 reply thread
  • You must be logged in to reply to this topic.