Software Solutions
Viewing 66 reply threads
  • Author
    Posts
    • #1542
      trashpandatrashpanda
      Participant

      I have a ABV387PRO board. It is having calibrating issues on a Windows 10 system. Software/drivers have been updated. To rule out that the board itself is failing, I would like to upgrade the firmware.

      Can you please send this file my way? 

    • #8000
      Anonymous
      Inactive

      Hi trashpanda,

      I will send you an email with the firmware file and instructions. 

      Please keep an eye out for the email.

      Craig 

    • #8001
      Anonymous
      Inactive

      Craig:
      Could you send this to me as well?  I am troubleshooting a ABV387S300 board that is spiking as well and want to try the firmware to rule out a failing board too.
      Thanks,

    • #8002
      Anonymous
      Inactive

      I am having the same issue with several of the machines within our elementary building.   We’re running OS 10.11.6.  I would also like to try the new firmware.  Please email me.  Thanks!

    • #8003
      Anonymous
      Inactive

      Hi @carawade1

      I will send you an email which you will receive shortly.

      Thanks,
      Adam
      Promethean Technical Support

    • #8004
      Anonymous
      Inactive

      I am having problems with pens not working on 2 ABV3785 since the new Activinspire 2.86693 update.  I have updated the Activdriver to 5.14.21. I am running OS 10.11. I would like to try the new firmware. 
      Please email me. Thanks!

    • #8005
      Anonymous
      Inactive

      Hello Dmnorris,

      Can I please ask what issues you are having with the ActivPen? Is there no calibration or interaction. We don’t want to update the firmware if not necessary.

      Thank you,

      Craig  

    • #8006
      Anonymous
      Inactive

      Hello,
      I noticed that some of our Promethean boards ABV387PRO have different firmware.
      Could you please send me the firmware too? 
      Thanks

    • #8007
      Anonymous
      Inactive

      Hi Michelebelotti,

      I have sent you an email with the latest firmware available for the 387Pro ActivBoard.

      If we can be of any further assistance please do not hesitate to get back in touch.

      Kind Regards,
      Paul
      Promethean Technical Support
    • #8008
      Anonymous
      Inactive

      Hello,

      I am providing support to a teacher with an ABV387pro experiencing the same problems and pens are unusable at this point. Have calibrated, updated Drivers and ActivInspire, replaced pens, checked cables. Firmware is last thing to try before replacing equipment. Currently on 8.04 Build 4 with no updates available.

      Please, if you could, email me the file as well. Thank you.

    • #8009
      Anonymous
      Inactive

      Hi @sjcastello

      I’ll send you an email with the upgraded V8.09 firmware which is for the ActivBoard 387PRO.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8010
      Anonymous
      Inactive

      Hello,

      We are experiencing some connectivity issues with a couple of laptops. We’d like to receive the latest firmware for our ActivBoard 387PRO boards.

    • #8011
      Anonymous
      Inactive

      Hello Dion,

      Thank you for your post.

      I will send you an email with the firmware file.

      Thank you,

      Craig 

    • #8012
      Anonymous
      Inactive

      Hi

      We are also experiencing some issues with our ActivBoard 387PRO’s running firmware version 8.04 Build 4

      Please can you email me the latest firmware available thanks, we have several of these boards throughout our school.

      Thanks
      Alex

    • #8013
      Anonymous
      Inactive

      Hi AlexS93,

      I’ve sent an email to you directly with the firmware information.

      I hope this helps.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8014
      Anonymous
      Inactive

      Hi ,

      can we have the firmware update

    • #8015
      Anonymous
      Inactive

      Hi rabahatmani,

      Thank you for your post.

      I’ve sent an email directly with this firmware file and instructions.
      I hope this helps,

      Kind regards,
      Adam
      Promethean Technical Support

    • #8016
      Anonymous
      Inactive

      HI Adam,
      I’m working on updating our boards to the latest firmware. We are running Mac’s with OSX 10.11.5 and above. They are all experiencing issues with the pens being able to be used throughout the day. I’ve tried all steps in previous threads before updating the firmware.  I’m upgrading from V8.04 Build 4 to V8.10 build 7. However, I’ve run across a few that continue to fail to update even after restarting a few times and making sure the drivers are up to date. Could you send me older firmware, perhaps ones after V8.04 build 4, to try? 

      Thanks!

    • #8017
      Anonymous
      Inactive

      Hi stephenssensei,
      Thanks for posting.

      The only firmware released after V8.04 was version 8.10.

      If this is happening on all of your ActivBoards, this could be in relation to the cables/computers being used. 
      What is the exact issue you are experiencing?
      If you log on with a local admin account, does the same issue happen?
      Have you tried to calibrate the ActivBoard since the firmware upgrade was applied? If not, please calibrate and see if this helps.

      You’ve mentioned that the drivers are up to date, please could you confirm the version you are using? This can be found by clicking on the ActivManager icon and selecting Control Panel. The driver will be listed at the bottom of this window.

      Thanks,
      Adam
      Promethean Technical Support

    • #8018
      Anonymous
      Inactive

      Hi Adam, 
      I’ve definitely checked cables to and from boards. The problem seems to be when teachers run Chrome. The pens stop working. After a firmware update they are better and no longer quit working after starting Chrome. I’m just having trouble installing the update on a few computers even after I logged in as the Admin in the computer. 

      The driver is 5.14.21.

      Any other suggestions? 

      Thanks!

    • #8019
      Anonymous
      Inactive

      Could you send me an updated Firmware for ABV387PRO.  Same issue as everyone else, Chrome kills the pens. Running V8.04 Build 4.  

    • #8020
      Anonymous
      Inactive

      Hi stephenssenseitiffanyg,

      Thanks for posting.

      I’ll send you both emails with this information.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8021
      Anonymous
      Inactive

      Please send me the Firmware also. We have begun to have the same issue on our elementary campus as well. We are running Windows 10 on a ABV387Pro boards. 

    • #8022
      Anonymous
      Inactive

      I am having the same issues as the others.  Windows 10, uninstalled and re-installed (with most current activdriver), still cannot calibrate.  Pen responds on the board but needs to be calibrated badly.  Light flashes a color change to blue when I touch the calibration screen but does not calibrate.  Would like to upgrade the firmware.

    • #8023
      Anonymous
      Inactive

      Hi rmartinawgrace,

      Thanks for posting.

      I will send you a firmware file with instructions and hopefully this will help with the issues you are experiencing.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8024
      Anonymous
      Inactive

      Hi Adam,

      I did the Firmware update as specified and am still having issues with the pen not responding correctly. It did seem to work a little better, but still spiking and skipping. Do you think it could now be the AC3 Electronics going bad.  HELP 

    • #8025
      Anonymous
      Inactive

      Adam, thank you for sending the firmware.  I installed the firmware as well and am still having the issue of not calibrating.  Light still changes to blue when I hover over it and the calibration screen pops up but will not respond to the pen.  The computer itself recognizes the pen, it just needs to be calibrated (which I cannot do successfully).  Running Windows 10 and the board is the ABV387.  Any other ideas on what I should do?  I had previously, unplugged, uninstalled, rebooted and re-installed the driver and software.  Have checked the Device Manager and all is well.  Activinspire is up to date.  Even tried closing Chrome as I saw the previous posts about Chrome causing issues.

    • #8026
      Anonymous
      Inactive

      Hi awgrace,

      I will reply back to your email.

      Thanks,
      Adam
      Promethean Technical Support

    • #8027
      Anonymous
      Inactive

      Hi rmartin,

      Thanks for your reply.

      I’ll send you an email direct so we can troubleshoot this issue further.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8028
      Anonymous
      Inactive

      Losing connection to a ABV378PRO board, and digital ink skips daily.
      Mac OS X 9.5.5
      ActivDriver 5.4.21
      ActivInspire Version: 2.8.66693
      Firmware Version: ActivBoard V8.04 Build 4
      Would like to update the firmware in hopes of fixing issues. Thanks.

    • #8029
      Anonymous
      Inactive

      Hi fossej,

      Thank you for posting.

      I have responded to your separate post you have posted on the link below:
      https://community.prometheanworld.com/en/discussion/7001565/losing-connection-to-a-abv378pro-board-updated-firmware-available#latest

      Thanks,
      Adam
      Promethean Technical Support

    • #8030
      Anonymous
      Inactive

      Also having issues with a ABV378PRO board at one of our primary schools.  Flame indicator light remains red, even after power cycling the board, changed USB cable, plugged into other USB ports etc.  PC is Windows 7 64 bit, ActivDriver has been updated from 5.7 to 5.14.21.  Flame indicator does turn blue if you hover a pen over it, but the board is not being seen by the computer.
      Only thing I haven’t tried is a firmware update – assuming the board has’nt had it’s firmware upgraded since it was installed however many years ago !!

    • #8031
      Anonymous
      Inactive

      ^^  Although a firmware update when I can’t get the PC and board to communicate, could be problematic !!

    • #8032
      Anonymous
      Inactive

      Hi Gary,

      Thank you for your post.

      If the ActivBoard is not being detected by the ActivManager it will not be possible to perform a firmware update, however we suggest you try the tests below, testing the board after each step:

      – try another USB port on the computer
      – try a power reset on the board. To do that, disconnect the USB cable, switch off the standby button, wait for about 2 minutes, connect the USB cable back again and wait for 1 minute. If the ActivBoard is still not detected, turn on the standby button again
      – try another USB cable connected directly to the ActivBoard, bypassing any wallboxes, faceplates, etc
      – try another laptop/PC which works fine with another ActivBoard

      Please let us know the outcome.

      Thank you

      Miguel
      Promethean Technical Support

    • #8033
      Anonymous
      Inactive

      Hi I too have the issues with pen not working at all. Have also tried a known good pen, same issues. Flame is white. I looked for a firmware update in active manager but says none available and the board is on 8.04. Could you send me the latest version so I can give that a try?

      Thank you,
      Kevin

    • #8034
      Anonymous
      Inactive

      Hi Kevin,

      Thanks for posting!

      We are happy to send the firmware via email, however we would need you to confirm the product code, it should be something like ABV378PRO each size has its own firmware so we want to be sure we are sending you the correct one.

      We look forward to your reply.

      Kind Regards,
      Paul
      Promethean Technical Support
    • #8035
      Anonymous
      Inactive

      Hi I’m also having issues with repeatedly having to recalibrate a board.  Can I have the firmware emailed as well?  It is for the same ABV378PRO. 

      Thank You,

      Jason

    • #8036
      Anonymous
      Inactive

      Hello PATech,

      Yes, of course.

      I will send you an email shortly with the file needed.

      Craig 

    • #8037
      Anonymous
      Inactive

      Hi @”Paul Promethean”,

      The board is an ABV378PRO model. Thank you.

      Kevin

    • #8038
      Anonymous
      Inactive

      Hello KThibeault,

      Thank you, I will send an email with the file and instructions shortly.

      Cheers,

      Craig 

    • #8039
      Anonymous
      Inactive

      Tech Specialist for a school district, encountering this exact same issue, across too many ABV378Pro boards.

      I would also like the firmware file to attempt update of the boards.

      Is it correct that with wireless connection, firmware update cannot be performed? I am able to update the ActivHub, but have to direct connect to the boards for firmware updates. Is this expected behavior?

    • #8040
      Anonymous
      Inactive

      Hi Adam

      We have these same activboards and cannot connect to them.
      Could you please send me the driver for the ABV387PRO boards.

      Thanks
      Kathy

    • #8041
      Anonymous
      Inactive

      Hello kat2nz,

      Please find below a link to the latest driver for your ActivBoard: 

      https://support.prometheanworld.com/product/activdriver

      Can you also check the ActivBoard has power, does the stand and LED in the top left corner light up? 

      Craig 

    • #8042
      Anonymous
      Inactive

      Sorry, I meant the firmware for the boards.

    • #8043
      Anonymous
      Inactive

      Hello kat2nz,

      No problem, I will send you an email with the firmware and instructions. 

      Cheers,

      Craig 

    • #8044
      Anonymous
      Inactive

      I’m having similar difficulties with the boards in my building with no interactivity.  Have updated drivers and connected directly to the board.  Could I get an email with the firmware?
      Thanks

    • #8045
      Anonymous
      Inactive

      Hello djguinan,

      I will send you a direct email containing the firmware and instructions. 

      Cheers,

      Craig 

    • #8046
      Anonymous
      Inactive

      Hello, I am looking for the most recent firmware update for the ABV378PRO. The current firmware is 8.04 build 4. Can you please email it to me?

    • #8047
      Anonymous
      Inactive

      Hi mafii101,

      We will send you an email shortly.

      Thank you

      Miguel
      Promethean Technical Support

    • #8048
      Anonymous
      Inactive

      I also need the firmware update if possible.  The spiking on the board has gotten quite bad and I am game to try anything before we replace the board.  What version is the firmware? Thanks!

    • #8049
      Anonymous
      Inactive

      Hello betsiv

      The latest firmware for a 378Pro ActivBoard is 8.10. Can you please confirm the size of ActivBoard you have? To help you find the model number please take a look at the below support article: 

      https://support.prometheanworld.com/article/?kb=1088

      Thank you,

      Craig 

    • #8050
      Anonymous
      Inactive

      We also have two of the AB378Pro boards and would like the firmware update please. Firmware now: 8.04 build 4

      Thanks.

      Mattias

    • #8051
      Anonymous
      Inactive

      Hello masugnen,

      We will send you an email shortly with a link to the firmware file.

      Thanks,
      Michael
      Promethean Support

    • #8052
      Anonymous
      Inactive

      Hi! I am having a few issues with some of the AB387Pro along with the AB587Pro boards. They will connect and stay connected for a day or so, then disconnect. I’ve updated the driver recently to the 5.15. I’ve changed connections to the board, and even changed computers. The latest firmware that one of my 387 boards has is 8.09. Is there a more up-to-date update and if so could you please send it to me?? I know this discussion is for a 387 but could you also send me the latest firmware update for the 587’s as well? I’m having some similar issues with a few of those as well. Thank you so much in advance!

    • #8053
      Anonymous
      Inactive

      Hello rlrhodes,

      The firmware for the 587pro is done via the internet. When the ActivBoard is connected, click on the ActivManager > Control Panel > Select the ActivBoard in the description > Click Upgrade > Select Internet > Load. 

      The 387pro ActivBoard firmware is already the latest version, the issue could be caused by the cabling. I know you have said that you have tried a few different things but if possible can you please test a known working cable connected directly from the computer into the both the main and hub electronics (see image below). 

      We look forward to hearing from you.

      Craig 

    • #8054
      Anonymous
      Inactive

      I also need the latest firmware for a ABV387PRO. Horizontal lines populate by the curser when I detach the USB cord

    • #8055
      Anonymous
      Inactive

      Hi desertman21,

      The issue you have pictured is unlikely to be caused by ActivBoard firmware.  Can you please confirm the operating system and ActivDriver version you have installed?

      We look forward to your reply.

      Kind Regards,
      Paul
      Promethean Technical Support
    • #8056
      Anonymous
      Inactive

      OS – 10.11.6
      Driver – 5.14.21

      When I clicked on Control Panel, it shows:

      Firmware – 8.04 Build 4
      Driver Version 5.13.9

    • #8057
      Anonymous
      Inactive

      Hi desertman21,

      Can you confirm the model name of your board? (do not post any serial numbers).

      Thank you

      Miguel
      Promethean Technical Support

    • #8058
      Anonymous
      Inactive

      Can we have the firmware update for the promethean ABV387PRO?

    • #8059
      Anonymous
      Inactive

      Hi Joost,

      You can obtain the ActivBoard 300 series firmware by clicking on the below link:
      https://support.prometheanworld.com/article/?kb=1038

      Please ensure that you select the correct download for your model of ActivBoard.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8060
      Anonymous
      Inactive

      I’d like to request this new firmware as well please.

    • #8061
      Anonymous
      Inactive

      Hi Bart,

      You can obtain the ActivBoard 300 series firmware by clicking on the below link:
      https://support.prometheanworld.com/article/?kb=1038

      Please ensure that you select the correct download for your model of ActivBoard.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8062
      Anonymous
      Inactive

      I am having the same issues at a school I support.  Could you please email me the link to the firmware update.  Current is version 8.09 Build 4.  Driver is 5.8.46.3

      Running on Windows 10 Education

      Thank you.

    • #8063
      Anonymous
      Inactive

      Hi VergoTech1,

      Thank you for your post.

      The most recent ActivDriver version is 5.17.13, you will want to make sure that you download and install (with the USB not connected to the computer) the most recent ActivDriver from our support site. https://support.prometheanworld.com/product/activdriver

      Can you confirm the model of your ActivBoard for us?

      You can obtain the ActivBoard 300 series firmware by clicking on the below link:
      https://support.prometheanworld.com/article/?kb=1038

      Please let us know if we can assist you further.

      Kind Regards,
      Maggie
      Promethean Technical Support

    • #8064
      Anonymous
      Inactive

      Flame indicator light is purple on my ABV387PRO. I checked for updates and installed, unplugged/replugged the USB cable, unplugged/replugged the power. Now I am thinking it may be firmware. I can’t find much more about a purple light. Please send files and instructions.

    • #8065
      Anonymous
      Inactive

      Hi Sam,

      When you turn the AMP standby button to red, what is the color of the flame on the board? 
      In order to get the firmware file click on this link https://support.prometheanworld.com/article/?kb=1038 to download the file. The instructions are also in that link.

      Thank you,
      Pam

Viewing 66 reply threads
  • You must be logged in to reply to this topic.