Interactive Whiteboards
Viewing 3 reply threads
  • Author
    Posts
    • #31476
      Gareth EdmondsonGareth Edmondson
      Participant

      Good morning all,

      In an attempt to upgrade a board last night the firmware installation didn’t work and now the board is not showing up at all in ActivManager.

      All the correct processes were followed. Firmware downloaded, USB cable was less than 3 metres. But it failed.

      Is there any advice on how to get the board back to working stock?

      Many thanks

      Gareth

    • #31500
      Adam H PrometheanAdam H Promethean
      Senior Moderator

      Hello Gareth,

      Thanks for your post. In order to advise you further, please can you confirm the following:

      • Were you trying to upgrade the firmware of an ActivBoard or ActivPanel?
      • Can you confirm the model of your Promethean hardware? (Please don’t post a serial number)
      • What was the reason for the firmware upgrade?
      • What version of ActivDriver is showing at the bottom-left of the ActivManager control panel window?

      We look forward to hearing back from you soon.

      Kind regards,
      Adam H

    • #31506
      Gareth EdmondsonGareth Edmondson
      Participant

      Hi Adam,

      Here are the answers:

      • ActivBoard
      • PRM-AB2-01
      • Wasn’t working with Windows 10 1909 and following various paths on this board that said we needed a latest firmware to get it to work with Beta drivers.
      • Driver of the software is: 5.18.19 – latest download (64 bit) – again as advised by all notes online.

      Strange thing is – other boards of this type are working in Windows 1909

      Same thing in our Maths dept – some legacy boards work with Windows 10 1909 and others do not (see other post).

      Thanks for reaching out.

      Gareth

    • #31537
      Craig PrometheanCraig Promethean
      Moderator

      Hello Gareth,

      Thank you for the details.

      Can you confirm the driver you have installed? Can you also confirm the firmware version you tried to upgrade the ActivBoard to?

      We look forward to hearing from you.

      Kind regards,

      Craig

Viewing 3 reply threads
  • You must be logged in to reply to this topic.