Software Solutions
Viewing 35 reply threads
  • Author
    Posts
    • #1561
      mb08353mb08353
      Participant

      I tried installing the activdriver on a linux machine using the instructions I found here: http://activsoftware.co.uk/linux/

      Unfortunately, they did not work. From what I can tell it looks like Promethean may have dropped support for Linux. Am I correct?

      Does anyone have the activdriver working on a recent version of Ubuntu (16+).

    • #8102
      Anonymous
      Inactive

      Hello mb08353

      We do still support Linux and I have provided below the files needed for the latest driver for 16.04:

      https://promethean.box.com/v/ActivAid1604-64

      https://promethean.box.com/v/ActivDriver1604-64

      https://promethean.box.com/v/ActivTools1604-64

      https://promethean.box.com/v/ActivRelay1604-64

      They will need to be installed in that order.

      Please let me know if you need any further support. 

      Craig 

    • #8103
      Anonymous
      Inactive

      I
      am installing this on an older machine. Do you have 32 bit versions of the software?
      I’m getting the following error: Wrong architecture ‘amd64’

      Thanks for the help. I really appreciate it.

    • #8104
      Anonymous
      Inactive

      Hello mb08353,

      Yes, please find links below for the 32bit versions:

      https://promethean.box.com/v/ActivAid1604-32

      https://promethean.box.com/v/ActivDriver1604-32

      https://promethean.box.com/v/ActivTools1604-32

      https://promethean.box.com/v/ActivRelay1604-32

      Please let us know if you need any further support.

      Craig 

    • #8105
      Anonymous
      Inactive

      Once I install the software, what’s the name of the program I’ll use to calibrate the pen and how can I find it?

    • #8106
      Anonymous
      Inactive

      Hello mb08353,

      You will calibrate via the ActivManager. You should see the white box with the Promethean logo, simply click on the box and calibrate. 

      Please let us know if you need any further support. 

      Craig 

    • #8107
      Anonymous
      Inactive

      Ended up getting the drivers working using a 64bit version of Lubuntu 16.10. Thanks so much for hooking me up with those drivers.

    • #8108
      Anonymous
      Inactive

      Hi @mb08353,

      Glad to hear that this has been fixed and working.

      Thanks,
      Adam
      Promethean Technical Support

    • #8109
      Anonymous
      Inactive

      Dear Promethean Technical support,
      I just got my new board set up. I was able to follow the links above to install the software for my 64 bit ubuntu 16.0.4 laptop. After installation, however, I don’t see the Active MAnager icon. When I type activmgr on command line, it gives a bunch of error messages and hangs. I tried uninstalling and reinstalling all the software in the order indicated above, but it didn’t help. It seems like there is some issue with QT.

      Also when I connect the board with VGA, linux OS sees the board but activcalibrate fails to detect the board. If you can comment on these, I’ll greatly appreciate it.
      Sash

    • #8110
      Anonymous
      Inactive

      Here is the error message I get when activmgr hangs
      sash@sash-ThinkPad-T450s:~$ activmgr
      System Locale Language: “en_GB”
      Locale Language: “en_GB”
      Translation file:  “activmgr_en_GB”
      “/usr/share/promethean/languages”
      Could not load QT language file

      ActivManager settings in  “/home/sash/.config/Promethean/Activmanager.ini”
      You can override the projector settings for the whole computer by creating the file  “/etc/xdg/Promethean/projector.ini”
      Engage2 Settings filename “/home/sash/.config/Promethean/engage2.ini”
      Engage2 Settings filename “/home/sash/.config/Promethean/engage2.ini”
      QMetaObject::connectSlotsByName: No matching signal for on_teacherProfile_currentIndexChanged(int)
      QMetaObject::connectSlotsByName: No matching signal for on_studentProfile_currentIndexChanged(int)
      Object::connect: No such slot mgrwidget::showMessage(const QString&, bool)
      QRect(0,0 2944×1080) QPoint(20,20)
      QMetaObject::connectSlotsByName: No matching signal for on_menuRegisterOther_triggered()
      QMetaObject::connectSlotsByName: No matching signal for on_menuCalibrate_triggered()
      QMetaObject::connectSlotsByName: No matching signal for on_menuCalibrate9_triggered()
      QMetaObject::connectSlotsByName: No matching signal for on_menuCalibrate16_triggered()
      QMetaObject::connectSlotsByName: No matching signal for on_menuCalibrate36_triggered()
      QMetaObject::connectSlotsByName: No matching signal for on_menuGesturesOnABTouch_triggered()
      QMetaObject::connectSlotsByName: No matching signal for on_menuGesturesOffABTouch_triggered()
      QMetaObject::connectSlotsByName: No matching signal for on_menuGesturesOnDavinci_triggered()
      QMetaObject::connectSlotsByName: No matching signal for on_menuGesturesOffDavinci_triggered()
      QMetaObject::connectSlotsByName: No matching signal for on_upgradeDevice_clicked(int,int)
      Loaded libfam.so.0
      Promethean: Open lock
      Promethean: Global locking…
      Promethean: Global locked…
      Promethean: Initialise board state
      Promethean: Global unlocking…
      Promethean: Global unlocked…
      Promethean: Unlocked count 0
      Promethean: Global locking…
      Promethean: Global locked…
      Promethean: locked count 1
      Promethean: Async for 0
      Promethean: Loaded TPH Description V:d48 P:a I#:0 FR:5 |FR|:15 OR:4 |OR|:63 IR:3 |IR|:15.
      Promethean: Loaded TPH Description V:d48 P:b I#:0 FR:7 |FR|:62 OR:6 |OR|:62 IR:5 |IR|:62.
      Promethean: Loaded TPH Description V:4b8 P:31e I#:0 FR:4 |FR|:0 OR:0 |OR|:0 IR:5 |IR|:16.
      Promethean: Found invalid device description with 5 fields!.
      Promethean: Loaded TPH Description V:4b8 P:326 I#:0 FR:4 |FR|:15 OR:193 |OR|:63 IR:3 |IR|:15.
      Promethean: Loaded TPH Description V:4b8 P:327 I#:0 FR:4 |FR|:15 OR:193 |OR|:63 IR:3 |IR|:15.
      Promethean: Loaded TPH Description V:4b8 P:61b I#:0 FR:4 |FR|:15 OR:193 |OR|:63 IR:3 |IR|:15.
      Promethean: Loaded TPH Description V:28e1 P:b001 I#:0 FR:7 |FR|:63 OR:6 |OR|:63 IR:5 |IR|:63.
      Promethean: Loaded TPH Description V:28e1 P:b002 I#:0 FR:7 |FR|:63 OR:6 |OR|:63 IR:5 |IR|:63.
      Promethean: Loaded TPH Description V:d48 P:c I#:0 FR:8 |FR|:15 OR:10 |OR|:255 IR:9 |IR|:15.
      Promethean: Loaded TPH Description V:d48 P:d I#:0 FR:8 |FR|:15 OR:10 |OR|:255 IR:9 |IR|:15.
      Promethean: Loaded TPH Description V:28e1 P:4 I#:0 FR:7 |FR|:63 OR:6 |OR|:63 IR:5 |IR|:63.
      Promethean: Found 0 third-party devices.
      Promethean: Stopping for device -1
      Promethean: File Monitor Starting.
      Promethean: File Alteration Monitor (FAM) Not Open : Polling instead.
      Promethean: Pollfile: /tmp/activboard
      Promethean: Global unlocking…
      Promethean: Global unlocked…
      Promethean: Unlocked count 0
      Promethean: Activ devices 0
      Promethean: Global locking…
      Promethean: Global locked…
      Promethean: locked count 1
      Promethean: Global unlocking…
      Promethean: Global unlocked…
      Promethean: Unlocked count 0
      Promethean: Global locking…
      Promethean: Global locked…
      Promethean: locked count 1
      Promethean: Global unlocking…
      Promethean: Global unlocked…
      Promethean: Unlocked count 0
      Pen state:  “XSSN.XSSN.XSSN”
      Promethean: Global locking…
      Promethean: Global locked…
      Promethean: locked count 1
      Promethean: Global unlocking…
      Promethean: Global unlocked…
      Promethean: Unlocked count 0

    • #8111
      Anonymous
      Inactive

      Hi Sash,

      Thanks for posting.

      Just to double check, have you installed the files in the correct order when installing the driver?
      They need to be installed in the below order:
      ActivAid
      ActivDriver
      ActivTools
      ActivRelay

      Thanks,
      Adam
      Promethean Technical Support

    • #8112
      Anonymous
      Inactive

      Dear Adam,
      Thanks a lot. I uninstalled and reinstalled the software. I discovered that when I type activmgr, a small icon appears on the upper right corner of my screen, while showing the above  messages on the terminal . When I right click on the icon, the calibrate and registration options are grayed out. I can launch the control panel, but it doesn’t see the device. May be I am not connecting it correctly? The installation guid doesn’t provide a whole lot of info on how to get started after connecting. Do you have any suggestions?

    • #8113
      Anonymous
      Inactive

      Hi Sash,

      It sounds like everything has installed correctly on the computer but the issue is relating to the connection to the ActivBoard (as the options are grayed out and not shown in the hardware tab). 
      I would suggest ensuring your ActivBoard has power and is connected using your USB cable.

      If you still have any issues, please let us know the model number of the ActivBoard you are using (excluding serial number).
      Please also let us know if the flame on the ActivBoard (top left corner) is lit, if so, what colour?

      Thanks,
      Adam
      Promethean Technical Support

    • #8114
      Anonymous
      Inactive

      I have found that everytime I restart my computer, I need to recalibrate the pen. Is there any way to make those settings stick?

    • #8115
      Anonymous
      Inactive

      Hi mb08353,
      Thank you for your post.

      The calibration settings are stored in: /etc/promethean/calibration on Linux.

      Please ensure that you have Full Read, write, modify and execute access to the above location for the calibration settings to be stored permanently. 

      It may be possible your ActivBoard requires a firmware upgrade if this does not help.
      Depending on your model of ActivBoard, please follow the below link for instructions on how to upgrade the firmware on your model of ActivBoard:

      https://support.prometheanworld.com/article/?kb=1162

      I hope this information helps.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8116
      Anonymous
      Inactive

      I have a /etc/promethean folder, but no /etc/promethean/calibration folder. Inside the /etc/promethean folder is a file called thirdpartydevices.ini. I changed the permissions for both the /etc/promethean folder an dthe thirdpartydevices.ini file to rwx for all users. Unfortunately, after a restart, the calibration settings for the pen still aren’t saved.

      The ActiveManager Hardware tab reads as follows:

      Description: ActivBoard
      Firmware: V3.76 Build 1
      Connection: USB
      Driver Version: 5.13.12
      ID: 1
      Serial Number…

      From what I can tell, it looks like I have the latest firmware (I checked https://support.prometheanworld.com/article/?kb=1391). Calibration settings are remembered when I use my Windows machine. Anything else I should try?

    • #8117
      Anonymous
      Inactive

      Dear All,
      Thanks for the comments and suggestions. Much appreciated! I got the board connected and somewhat working. One problem still persists, I am unable to use the ubuntu launcher from the activpanel. The only item in the launcher that works from the activpanel is the workspace. Is there a way to launch applications on the laptop by touching the icons on the activ panel?
      Thanks for your input in advance
      Sash

    • #8118
      Anonymous
      Inactive

      Hi mb08353

      If the permissions were incorrect at the time of installing the ActivDriver, it is possible that this hasn’t created the caibration folder.
      Now that you have checked the permissions and these are correct, please uninstall your current ActivDriver and re-install. 
      Hopefully this will help with the issue.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8119
      Anonymous
      Inactive

      I tried what you said, but still no luck. I see no calibration folder. I did notice that the description for the activdriver says:

      The kernel mode and X11 drivers for Promethean ActivBoard and ActivHub.
      You need to install the non open source activtools package in order to calibrate your board. Compatible with Xorg 6.8 and later (including 7.x).

      Is there a different version of the activdriver I should be installing?

    • #8120
      Anonymous
      Inactive

      Hi mb08353,

      Thank you for your reply.
      What version of Linux is being used?

      Earlier in the post we supplied both 32 and 64bit drivers for the ActivDriver, are these being installed in alphabetical order? I.E ActivAid>ActivDriver>ActivTools>ActivRelay

      Thanks,
      Adam
      Promethean Technical Support

    • #8121
      Anonymous
      Inactive

      Yes.

    • #8122
      Anonymous
      Inactive

      Hi mb08353,

      What version of Linux are you currently using?
      Are you still having to re-calibrate each day? 

      Thanks
      Adam
      Promethean Technical Support

    • #8123
      Anonymous
      Inactive

      Hi Adam,
      When you have a chance, please can you take a look at my post above.  I am only able to use the board as a second display without any touch functionality in linux.  Am I doing something wrong?
      Sash

    • #8124
      Anonymous
      Inactive

      Hi sash,
      Thanks for posting.

      Could you make sure that your ActivBoard is set to be the primary display and then calibrate?
      The ActivDriver doesn’t allow extended desktop calibration, as such you would need to have the ActivBoard as the primary display and this should start to work.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8125
      Anonymous
      Inactive

      Hi Adam,
      Thanks for the suggestion. That fixed the problem, well, almost. When I turn off the built-in display, the panel becomes primary and I can use touch features, although the typing needs to be done through the keyboard. When I turn the built-in display back on, it defaults to primary and the panel can be used only as an additional display. I am happy with this solution, at least it allows me to use the touch features of the activ panel. What a wonderful product! Thank you very much for all your help.
      Sash

    • #8126
      Anonymous
      Inactive

      Hello:

      I’m new on this forum. My question is: I have a Promethean Celver Board 3, that I want to use with Ubuntu. What shall I do?
      Can I use ActivClever driver?
      Thanks in advance.

      David RR

    • #8127
      Anonymous
      Inactive

      Sorry, I mean Cleverboard 3

    • #8128
      Anonymous
      Inactive

      Hi davidrr100,

      The Clever Boards aren’t part of the Promethean product range. (See products under Interactive Whiteboards for all Promethean ActivBoard models: https://support.prometheanworld.com/

      We would suggest referring to the manufacturer for guidance on getting this to work on your computer.

      Kind regards,
      Adam
      Promethean Technical Support

    • #8129
      Anonymous
      Inactive

      Hello!
      Is it possible to have these packages working for 64-bit Debian Wheezy/Jessie/Stretch?

    • #8130
      Anonymous
      Inactive

      Hello ptoivola,

      We currently do not support Debian, we currently only support Ubuntu for Linux. 

      We may support Debian moving forwards but not at the moment. 

      Thank you for contacting us.

      Kind regards,

      Craig 

    • #8131
      Anonymous
      Inactive
      The first thing is to thank for the good technical support.
      I use ubuntu 16.04 version 32 bits.
      I want to download the software for 32 bits, but the download links are broken, they do not work.
      Can you fix the links to download the software for ubuntu 16.04 version 32 bits?
      Thank you very much for your attention.

      *********************************************************

      Lo primero es dar las gracias por el buen soporte técnico.
      Yo utilizo ubuntu 16.04 version 32 bits.
      Yo quiero descargar el software para 32 bits, pero los enlaces de descarga están rotos, no funcionan.
      ¿Pueden ustedes arreglar los enlaces para descargar el software para ubuntu 32 bits? 
      Muchas gracias por su atención.
    • #8132
      Anonymous
      Inactive

      Hello yoda,

      We now have an article which goes into detail about how to install the ActivDriver for ubuntu 16.04 located here.  

      Thanks,
      Michael
      Promethean Support

    • #8133
      Anonymous
      Inactive
      Dear Michael
      Thank you so much for your help
      **************************************

      Querido Michael
      Muchisimas gracias por su ayuda
    • #8134
      Anonymous
      Inactive

      As of this date, I’ve installed the latest builds available onto my Ubuntu 16.04 64 bit laptop, in the order listed, via Synaptic:

       – activaid
       – activdriver
       – activtools
       – activrelay
       – activinspire

      Installs appear to be successful.

      My Promethean board is physically connected via USB cable. It is model ABV378E100. I’m located in the USA. When I open activinspire, it freezes on the splash screen, and the light on the board remains red. I’ve tried both US and en-gb versions with the same result. 

      The white Promethean panel icon appears in the upper right-hand corner of my screen. When opened, no devices are listed. Further, I’ve attempted to connect via BT, but the board does not appear on the list. The board has power to it. 

      Can you please tell me what I’m missing?

    • #8135
      Anonymous
      Inactive

      The Promethean board model is PRM-AB378-01.

    • #8136
      Anonymous
      Inactive

      Hi tzietz,

      Thanks for posting.

      It sounds like you may have 2 issues here.

      ActivInspire launching and connection with the ActivBoard.

      Looking at the ActivBoard first, this needs to be connected via a USB cable. This model does not have Bluetooth. 
      Once connected and the ActivDriver has been installed, the flame in the top left corner of the ActivBoard should light up white. 
      This means a connection has been made.
      If you are using any wallboxes/connectivity plates, try and bypass this and connect directly to the USB port on the back of the ActivBoard (located behind the flame) and see if this works.
      If you get the same issue, connect a computer that is known to work with another ActivBoard of the same model and see if this works.

      For ActivInspire, this would usually freeze on the splashscreen if you do not have Flash and Java installed. Please ensure that this is installed.

      Kind regards,
      Adam
      Promethean Technical Support

Viewing 35 reply threads
  • You must be logged in to reply to this topic.