Interactive Flat Panels
Viewing 3 reply threads
  • Author
    • #1544

      Has anyone have had any issues with Promethean ActivPanel APT2-70 while using Chrome Browser on a PC (windows 7)? For example, while Chrome Browser is open I am unable to open a new tab or do any interactive,  it simple becomes unresponsive. But if I touch anywhere in the desktop it works just fine. Sometimes it fixes itself when I reload the Chrome browser. Other times I make sure I am running the latest Chrome browser version. Any advice?

    • #8067

      Hi and thanks for posting.

      This issue is relating to Google Chrome and not the ActivPanels (hence why it’s working on the desktop).
      Google Chrome doesn’t always detect touch inputs like a normal mouse input as such you may need to change the below settings to see if this helps:

      Type chrome://flags in their address bar.

      Pay special attention to the warning message at the top of the screen:

      WARNING These experimental features may change, break, or disappear at any time. We make absolutely no guarantees about what may happen if you turn one of these experiments on, and your browser may even spontaneously combust. Jokes aside, your browser may delete all your data, or your security and privacy could be compromised in unexpected ways. Any experiments you enable will be enabled for all users of this browser. Please proceed with caution.

      If you are happy to continue, look for the setting labeled Enable Touch Events.

      Set this to Enabled.

      Kind regards,


      Promethean Technical Support

    • #8068

      I having another issue related to Google Chrome. While working in Google Chrome after a while the curser disappears. If I switched to the desktop, I am able to see the cursor once again. Is there a work around?   We are a district that uses G-Suite for Education, so you will know we use Google Chrome for everything.  Please advise. 

    • #8069

      Hello eaguirre,

      Though not a specific answer, some types of plugins and add-ons can hide the mouse cursor. Does this happen on all web pages, or just select pages?

      Here are some suggestions that may work.

      If it’s not the web page that is trying to hide the pointer (does this happen on different pages?), then it could just be your mouse pointer options:

      Go into Mouse properties and make sure hide pointer while typing isn’t checked.
      You can also stop Shockwave Flash plugin in Chrome Task Manager to solve this problem

      Please let us know if the issue persists,


Viewing 3 reply threads
  • You must be logged in to reply to this topic.