Software Solutions
Viewing 21 reply threads
  • Author
    Posts
    • #737
      susu
      Participant

      OS X 10.10.4 Yosemite / ActivInspire v2.4.66096

      A recent tweet by @planet_tweets [1] said: ‘We’re running Yosemite w/ latest versions of Java & ActivInspire. Our tech support team can help, if needed.’

      I have the latest Java runtime installed from Oracle [2].

      After a clean install of ActivInspire then running it, it’s asking for a legacy Java version to be installed: ‘To open “ActivInspire” you need to install the legacy Java SE 6 runtime.’ Clicking on the ‘More Info’ button that appears, takes you to Apple’s Java for OS X 2015-001 page, which contains a download that would install the legacy Java RE [3].

      Can you point me in the right direction as to how to get ActivInspire to use the latest Java version as per @planet_tweets comment please?

      Many thanks,

      S

      [1] https://twitter.com/planet_tweets/status/616266516011581440
      [2] http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html
      [3] https://support.apple.com/kb/DL1572?locale=en_US

    • #5073
      Anonymous
      Inactive

      Hello,

      Thank you for contacting Promethean Tech Support.

      I am sorry you are experiencing some issues with ActivInspire and Yosemite OS.

      This error is usually encountered when the Java installation has gone wrong, or when Java has been corrupted for some reason.

      In this case, the best thing would be to perform the following actions in this order:

      1) Remove the version of Java currently installed (you may find this link useful: https://www.java.com/en/download/help/mac_uninstall_java.xml)

      2) Uninstall ActivInspire

      3) Reboot your MAC machine (please note: this is an integral part of the solution)

      4) Re-install ActivInspire

      5) Re-install Java

      If the issue persists, please do not hesitate to contact us again: we will be happy to consider other available options.

      Kind Regards,

      Riccardo
      Promethean Technical Support

      http://www.prometheankb.com
      http://www.prometheanplanet.com

      To leave us your feedback, please use the form at: http://promethean.force.com/lf/feedbackuk

      For full Technical Support contact information, please visit http://www.prometheankb.com and search for Article 10860.
      For full details around Product Registration and ActivCare Warranty please visit http://www.prometheanworld.com/warranty

    • #5074
      Anonymous
      Inactive

      Thank you for the quick response; unfortunately I have already been through that procedure – the issue appears consistent and repeatable.

    • #5075
      Anonymous
      Inactive

      Hi, sorry to hear that the previous suggestion did not help.

      Please could you try removing the Java you have currently installed and try installing the version from the link below:

      https://support.apple.com/kb/DL1572?locale=en_GB

      Please let us know if this resolves your issue.

      Kind Regards,
      Paul

      Promethean Technical Support

    • #5076
      Anonymous
      Inactive

      Thank you for your assistance, but I think you have misunderstood my original post.

      Installing Java 6 will unfortunately not resolve the issue here.

    • #5077
      Anonymous
      Inactive

      Thank you for your assistance, but I fear you have misunderstood my original post.

      A recent tweet by @planet_tweets [1] said: ‘We’re running Yosemite w/ latest versions of Java & ActivInspire. Our tech support team can help, if needed.’

      Are you able to help in getting ActivInspire to work with the latest version of Java please, as @planet_tweets suggests?

      Many thanks,

      S

    • #5078
      Anonymous
      Inactive

      Hi,

      Please install the latest Java, not version 6.

      Repeat the steps exactly as explained in our previous response, but then install the latest version of Java – have you tried that already?

      Thank you
      Miguel
      Promethean Technical Support

    • #5079
      Anonymous
      Inactive

      Thank you, you mean to repeat the instructions in the second post of this thread using Java 8 RE? I’ve done that twice now, but I’ll give it another go – back in a while.

    • #5080
      Anonymous
      Inactive

      Java SE Runtime Environment (build 1.8.0_51-b16) uninstalled
      ActivInspire 2.4.66096 uninstalled
      Reboot
      ActivInspire 2.4.66096 reinstalled
      Java SE Runtime Environment (build 1.8.0_51-b16) reinstalled

      No change in outcome though, ActivInspire still asks for the legacy Java SE 6 runtime on startup.

    • #5081
      Anonymous
      Inactive

      You can install the Java 8 RTE for use with the ActivInspire
      software.  However, you may be prompted
      by the software to install a part of the Java 6 RTE from Apple’s support page.  This is due to a change in how OS X handles
      Java made after Java 6. 

       

      What is being downloaded for installation from the Apple Support article referred
      to previously
      is a fix which uses parts of the Java 6 RTE to correct some
      issues with how Java is handled in OS X 10.7 and above.

       

      In our experience, this fix can be applied either before or
      after Java 8 is installed; the Computer (and ActivInspire) will recognize Java
      8 as being in place in either case.

      (Support Case 00564439)

    • #5082
      Anonymous
      Inactive

      You’re saying that if I want to run ActivInspire on Yosemite, I have to install the legacy Java 6 RE?

    • #5083
      Anonymous
      Inactive

      Hi,

      Thanks for your reply.

      I will escalate this issue for yourself.
      As such we will be in touch with yourself via email soon.

      Thanks.
      Adam

    • #5084
      Anonymous
      Inactive

      Thank you very much for your help.

      In the meantime, are you able to give me a yes or no answer to my last question? If it’s not possible to install ActivInspire on Yosemite without Java 6, then I can quite happily abandon working on that, and move on to looking at other workarounds.

      I do have a tested and working plan B, but it’s not really practical for a large network, and whilst it works, it’s a bit fiddly to use: ActivInspire running on Ubuntu, via VirtualBox on Yosemite.

    • #5085
      Anonymous
      Inactive

      Hi,

      This is the process from the rror message:
      1. Get the error
      2. Click More Info
      3. Install Java 6 from the link.
      4. Reboot
      5. Test Inspire (it should now open).
      6. Upgrade Java to the latest version.
      7. Reboot
      8. Inspire should still carry on working.

      ActivInspire requires certain components that are in the legacy Java installation in order to initialise correctly the first time it is run on 10.10.
      Once it has been opened for the first time you then install the latest Java version.

      Thank you

      Miguel
      Promethean Technical Support

    • #5086
      Anonymous
      Inactive

      Thank you, this is sounding quite hopeful.

      You are saying that Java 6 is only needed for the first time ActivInspire is started, so after completing your 8 stages as above, Java 6 can be uninstalled as it is no longer needed, and ActivInspire will continue working normally?

    • #5087
      Anonymous
      Inactive

      Promethean Technical Support replied to my question ” You’re saying that if I want to run ActivInspire on Yosemite, I have to install the legacy Java 6 RE?” by email with “Thank you for confirming. Yes that is correct”.

      As far as I can see, ActivInspire on Yosemite appears to ignore any newer version of the Java RE that is installed (installing the latest Java RE appears to serve no purpose, unless you need it for something else). Apple’s Java 6 RE and Oracle’s Java 8 RE are completely separate installations, and live on separate parts of the disk. Installing the Java 6 RE then installing Java 8 RE does not upgrade the Java 6 RE, you just get two separate versions of Java RE.

      As Oracle says [1] “Keeping old versions of Java on your system presents a serious security risk.”

      Can I ask that Promethean amend the system requirements for OS X, to make it that clear that Apple’s Java 6 RE is required for the software to run? The information currently on the system requirements page appears to be incorrect, and @planet_tweets comment on Twitter (whilst accurate) was a little misleading.

      I will use my plan B solution as given above until ActivInspire is updated to remove its dependency on the Java 6 RE.

      Thanks for everyone’s assistance in helping to resolve this.

      [1] http://java.com/en/download/faq/remov…

    • #5088
      Anonymous
      Inactive

      Hi,

      Thank you for your response.

      Note that we will look at changing the specification sheets.

      The reason for this is the Equation Editor (which is the Java component that needs Java to run) is only supported with Apples Legacy Java application.

      Thank you

      Miguel
      Promethean Technical Support

    • #5089
      Anonymous
      Inactive

      Thank you; do you know when ActivInspire will be updated to remove this dependency? Will it be before the start of this coming academic year?

    • #5090
      Anonymous
      Inactive

      Hi, three weeks have passed since the comment above; can I take it that the silence means that the software will not be updated to remove this dependency? I note that the specification sheets have yet to be corrected.

    • #5091
      Anonymous
      Inactive

      Hi Su,

      The specification sheet has not been updated but is with our team to review any changes.

      Please be aware that the dependency will not be removed at the moment, we have already passed your request to the development team for this be to reviewed.
      Should they update this in future versions of ActivInspire we will let you know.

      Thanks,
      Adam
      Promethean Technical Support

    • #5092
      Anonymous
      Inactive

      Hi, 
      I m having the same problem. I got a new Mac and I installed ActivInspire. When I try to open it it says: “To open “ActivInspire” you need to install the legacy Java SE 6 runtime”. I go to the link, I try to install an older version and it tells me it is not possible as I already have the newest version. Can you help?

      Thanks!
      María

    • #5093
      Anonymous
      Inactive

      Hi mflorenzano,

      Have you tried to remove the current version of JAVA and install the old one?

      Thank you

      Miguel
      Promethean Technical Support

Viewing 21 reply threads
  • You must be logged in to reply to this topic.