Interactive Whiteboards
Viewing 8 reply threads
  • Author
    • #18201
      Jonathon WilsonJonathon Wilson

      Hi All,

      As our school laptops are all running 1903 I’ve been going around updating boards with the new firmware today. First couple went without issue but the third has given me significant grief and stopped me in my tracks.

      It’s a ABV587PRO that I’ve just updated to V8.65 Build 1 (was upgraded from 8.60 Build 12), which was working completely fine (aside from the BSODs) until the firmware update. The board is detected correctly in ActivManager but when I attempt calibrations the pen touch detection is extremely intermittent (flame light often stays white, sometimes flicks to light or dark blue momentarily). If I stick with it and try numerous times I can eventually calibrate but its nowhere near usable enough to do writing with.

      At this point if working in HID mode cannot be fixed I’d settle for being able to roll back to older firmware and live with using the BETA Driver – is this possible?

    • #18209
      Craig PrometheanCraig Promethean

      Hi Jonathan,

      I think before we start looking at rolling back the firmware, can you please remove all of your old and current ActivDrivers, reboot the computer and install the latest driver (not the BETA).

      Once complete, please test the calibration and let us know the results.

      Kind regards,


      Promethean Technical Support



      • #18244
        Jonathon WilsonJonathon Wilson

        Hi Craig,

        The computer attached to this board has never had the Beta driver but I’ve tested as you’ve suggested and also borrowed laptops & pens from another working room that already had the HID update and run the latest non-beta ActivDriver and so far the results are consistent.

        When running the calibration I have to repeatedly try tapping the dots before the pen detection cuts in momentarily (flame goes blue) and registers the touch – it means i can eventually calibrate the board but takes a number of minutes to complete and once done the pen detection is so intermittent I can’t successfully write a single letter in ActivInspire.

        Again, board was working 100% fine before the firmware update.

    • #18253

      Hi Jonathan,

      Thanks for your reply and letting us know.

      Can I ask what version of the ActivDriver and ActivInspire software is?

      Does writing in applications such as MS Paint also have the same issues?



      Promethean Support

    • #18255
      Jonathon WilsonJonathon Wilson

      Hi Adam,

      I’m not at the school again until tomorrow but can answer a couple of questions – ActivDriver is 5.8.12. I don’t have the version of ActivInspire but it’s a build released within the last 6 months.

      I haven’t tried in MS Paint specifically but the issue also occurs when attempting to move the cursor around the screen with no applications open – after moving it around a bit the cursor will snap in and follow the pen correctly for a second or so before the pen is no longer detected.

    • #18260

      Hi Jonathon Wilson

      Thanks for your reply.

      Upon investigating your issue, this is due to the HID firmware being applied to an older version of firmware that was on the ActivBoard (8.60 Build 2 you mentioned).

      What you will need to do is roll back to a previous firmware version and ensure that you are using the latest one that is detailed on the article below:


      Once you are using the last firmware, upgrade to the HID firmware and then after the upgrade, please follow these steps:

      -Power off the ActivBoard at the amplifier by pressing the On/Standby button. Ensure that the button is now red.
      -Disconnect the USB cable from the computer.
      -Reboot the computer.

      This should help with your issue.


      Kind regards,


      Promethean Support

    • #30252
      Sergey ToropovSergey Toropov

      Good day!
      I have updated the firmware version from “8.61 build 10” to “8.65 build 1” using ActiveManager.
      Got the same problem with pen and interaction.

      Rolled back using the file

      It works poorly like a starter topic. No magic happened.

      Please help me where to get the firmware 8.61 build 10.
      It worked fine with this firmware.

    • #30281
      Paul PrometheanPaul Promethean

      Hi Sergey,

      I do not have 8.61 available as this was the very first firmware released on the 500 series however the one up from this but pre 8.65 is wholly dependant on the size of your ActivPanel. for ABV578PRO for ABV587PRO for ABV595PRO

      Please only try the file that matches the model number of your ActivBoard as putting the wrong file on can damage your ActivBoard.

      Kind regards,


      Promethean Technical Support


    • #30324
      Sergey ToropovSergey Toropov

      Thank you Paul!

      But, this firmware is the same as in the link above. 196KB 8.63 build 2.

      After the firmware, I removed all ActiveDrivers. I removed all the AtivInspare software. Restart the PC.
      Installed the oldest driver ActivDriver_x64 v5.8.46 setup.exe (which I had).
      Did the calibration.

      Works well now.

    • #30338
      Eddie PrometheanEddie Promethean

      Hi Sergey,

      Thank you for letting us know that. We are happy all has been worked out.

      Please let us know if we can be of further assistance.

      Best regards,


Viewing 8 reply threads
  • You must be logged in to reply to this topic.