Projectors

This topic contains 7 replies, has 6 voices, and was last updated by  Anonymous 1 year, 1 month ago.

  • Author
    Posts
  • #3235

    Anonymous

    The power light is on but when you turn it on, all the LED lights go off and the fans run. Lamp doesn’t come on. Lamp doesn’t flash or anything. I have power-cycled the projector and tried a known good lamp. Any ideas on what could cause this?

  • #13673

    Anonymous

    Hello jlittleton,

    If possible, it may be worth testing with another known
    working power supply. It could be that the unit is not getting enough power to
    remain on and fully powered.

    If you do try a known working power supply and the issue
    continues please let us know.

    Thank you
    Martha
    Promethean Technical Support

  • #13674

    Anonymous

    Plugged a known good power cable directly into the projector in a known good outlet and I get the same result.

  • #13675

    Anonymous

    Hi jlittleton,

    We are going to send you an email directly using the email you have used to create your account. Your case number will be 926732. 

  • #13676

    Anonymous

    I have the same problem. Did you find the solution?

  • #13677

    Anonymous

    Hello Kellidillard,

    We are going to send you an email directly using the email you have used to create your account. Your case number will be 960173.

  • #13678

    Anonymous

    I have a similar issue.  My PRM-35 has a green solid light but nothing happens when I try to turn it on with the remote.  I tried this projectors remote with another PRM-35 and the remote works fine, I also tried another remote on my projector and nothing.  The green power light just remains on solid.  It never blinks, changes color or goes off.  I power cycled the projector which had no effect.  Is there a hard reset on the PRM-35 or a manual power button anywhere?

    St. Joan of Arc
    IT Administrator
  • #13679

    Anonymous

    Hi sjaitamin,

    Thanks for posting.

    I’d recommend powering off the projector for 30 minutes and then powering back on to see if this does anything with the remote.

    If you still encounter the same issue, please do not hesitate to contact Promethean Support directly and provide your projector serial number.

    Kind regards,
    Adam
    Promethean Technical Support

You must be logged in to reply to this topic.