Projectors

This topic contains 3 replies, has 3 voices, and was last updated by  Anonymous 1 year, 9 months ago.

  • Author
    Posts
  • #2873

    Anonymous

    A Promethean projector that was working fine up until last week, just stopped finding the source. I have tried different cables (all working in other units), different laptops (all have the same problem) and selecting different ‘sources’ on the projector. There is still just a blue screen that says source cannot be found. The unit then turns off after the five minute window. Is there anything else I can be doing to troubleshoot? Thank you. 

  • #11921

    Anonymous

    Hi k_weber,

    Thank you for your post.

    Try to do a factory reset and see if that makes a difference.

    Also please let us know the model of the projector to see if we can advise you further.

    Thank you

    Miguel
    Promethean Technical Support

  • #11922

    Anonymous

    Hello and thank you for your help. I have tried the factory reset and this unfortunately didn’t work. The model of the projector is PRM-30. Thanks a lot for any assistance you can provide.

  • #11923

    Anonymous

    If the Computers and cabling in use are able to work with other PRM-30 projectors, that would place the cause of this issue with this particular PRM-30 projector.

    As these projectors are outside of their warranty coverage, we cannot provide any warranty replacements or service for them.

    For information regarding an out-of-warranty repair for this unit, we would advise reaching out to Panasonic at 1-888-337-1215 (option 1).

You must be logged in to reply to this topic.