Interactive Whiteboards

This topic contains 49 replies, has 22 voices, and was last updated by Adam K Promethean Adam K Promethean 1 week, 2 days ago.

  • Author
    Posts
  • #16906
    Jeremy Cherpeski
    Jeremy Cherpeski
    Participant

    Systems with Windows 10 (build 1903) driving ActivBoards using ActivDriver 5.18.12 are experiencing bluescreens repeatedly — when we roll back to Windows 1809 it works with no bluescreens.  When will Promethean have a fix so older boards can be used with Windows 10 (build 1903)?  The systems affected are dell Optiplex 3060, Optiplex 3040, Latitude 5450, Latitude 5470.  ActivPanels don’t seem to be having any issues, just the older boards.

  • #16928

    This issue is with our developers, who are researching and working towards a solution for this behavior. We do not have any information on a timeframe for which any such fix would be found and implemented; any such release would be announced on the home page of this community or on the front page of our support website.

     

    In the meantime, we are still collecting information about this issue to help with our teams’ investigation into this issue.  Such information would include:

    • The model or models of ActivBoard the computer experiencing this behavior is connecting to
    • How many of each model of Activboard are affected
    • The version number of Firmware listed with those boards in the ActivManager
    • What activity or actions that were performed at or with the Board just before the error occurred

     

    • #17696
      stephenlawJSRHS
      stephenlawJSRHS
      Participant

      We are experiencing this as well and the problem is growing. Microsoft is pushing out 1903 so any staff laptop receiving this feature update is experiencing the problem. Any Windows version prior to 1903 is not.

      We only have 300 series boards and the firmware is 8.10_Build7. ActivDriver 5.16.5 and 5.18.12 are effected with Windows 1903. BSoD seems to happen when the user uses the pens with ActivInspire.

      Really need an updated driver. We have ~55 boards in play and as laptops roll up, this is going to snowball. We have 6 definite staff with this problem and others are holding off on restarts to keep 1903 from installing to keep their boards working; which isn’t a good thing as we need restarts to update our AV software on a regular basis.

    • #17697
  • #16933
    Jeremy Cherpeski
    Jeremy Cherpeski
    Participant

    Most of our promethean boards are activboard 300 series (dark grey border) — it seems to happen during interactive use in the activinspire app.  The crashes are varied, though and can happen at anytime inside the activinspire, but sometimes it will be days between crashes.  The Firmware on all the boards is V8.04 Build4 and they are all connected via USB.  This behavior is present on most of our boards in the district that are running windows 10 (build 1903) — on some systems I have rolled the device back to windows 10 (build 1809) and the problem goes away.  The models affected are:  Dell Optiplex 3040,3060,3020, and Latitude 5470 and 5450.  I would say i have about 30-40 systems spread out between 5 sites that are exhibiting this crash behavior pretty regularly, but it could be higher.  We have 3 sites that are running windows 10 (build 1809 and 1803) with an ActivBoard 300 in every classroom and no crashes are occurring.

  • #16950
    Adem Promethean
    Adem Promethean
    Moderator

    We will pass your case with the details you have provided to the software. Please sign up to the announcements in these forums and you will be notified of new versions available when released and  its potential fixes.

  • #16964
    CJ Meyer
    CJ Meyer
    Participant

    This issue is affecting my district also.  We have around 30 boards doing this and creating a mess.  I do not want to roll back to a older load of windows as the security threat will create problems for our network.  Has there been any word on an ETA for a fix?  i have a ticket it and it seems they are aware of the issue but have not helped on a time.

     

    Was this not tested during the beta release?  Do they know what is actually the cause?  Is there any work around that do not involve taking away critical updates to windows?  Anything is appreciated as 65 percent of our district is down.  The other 45 percent are on Smart Notebook and have zero issues.

  • #16965
    Steven Schaefer
    Steven Schaefer
    Participant

    We are also experiencing this issue on many of the systems in our district.  We are using Lenovo M700 and M720Q desktops.  A close look at the memory dump seems to point to the driver file ACTIVhidmini.sys dated 10/30/2012 6:13pm.  most of our boards are on firmware version V8.04 driver version from the Activmanger control panel is V5.8.46.3

    I can provide one of our memory dumps if necessary.

     

  • #17014
    Chris Kuntzman
    Chris Kuntzman
    Participant

    We are also having this issue and are very frustrated about it.   Our staff is very unhappy right now.  Please get this fixed as soon as possible.  We have all HP Probook 450 G6’s that its happening on.  We have about 60 in all that have reported an issue so far.  We are only in our first 10 days of school.

     

    The model or models of ActivBoard the computer experiencing this behavior is connecting to

    Mostly:  ActiveBoard  387 pro   &  ActvieBoard 387’s

    How many of each model of Activboard are affected

    100%

    The version number of Firmware listed with those boards in the ActivManager

    ActivBoard  V8.04 Build 4,    Driver V 5.8.46.3

    What activity or actions that were performed at or with the Board just before the error occurred

    Doesn’t matter,  it can me a web site, it can be inside activeInspire, it can be just sitting there.

     

  • #17034

    Hi all,
    The issue with the latest Windows 10 1903 build causing blue screen crashes with our older ActivBoard range is currently being investigated by our product and development teams.

    At this time the only workaround is to downgrade to an older build of Windows 10.

    We will update this thread as and when we get updates from the product and development teams.

  • #17040
    Richard Ziemba
    Richard Ziemba
    Participant

    We have a lot of these old boards, in fact they are the primary boards in our rural district, but we have struggled with this issue for two weeks now. Promethean is working with us to get this resolved. They have some drivers they are working on and trying to make sure they are going to fix the issue and not break anything else before they release them. Ultimately they are working to fix a problem which was created by Microsoft.

  • #17042
    CJ Meyer
    CJ Meyer
    Participant

    They have a Beta Driver out currently and we have been using it for about 2 days.  I have had small issues with it as far as installing it before uninstalling the old driver.  I just assumed it would uninstall the older version and then replace with the beta driver.  It seems to work with no issues other than that.  However we have not had it very long.  I have not heard much from them even as a beta tester.  I agree the process/communcation they are using to help out districts has been very lackluster.

    In one email from them they claimed they built a driver for build 1903 but it did not include the “older” boards.  We have boards from them that are maybe 4 years old and they are calling them old.  I don’t like the fact they have seemed to give up on making sure the “older” boards are supported.  Smart seemed to do this years ago and that’s why a lot of districts have switched to Promethean.  I just hope this isn’t a sign of future problems with what they are calling “old” Boards 🙁

     

     

  • #17043
    CJ Meyer
    CJ Meyer
    Participant

    Also i would like to add.  I do not believe rolling back to the older version of windows from 1903 is a very safe “work around”.  Opening our districts up to security problems that wont have the correct patching is a nightmare for our student data and privacy.

    That and 1903 was a pretty long install…. really don’t want to do that all over again

  • #17046
    Brandon10
    Brandon10
    Participant

    We are expirecing the same issue in our District. We have them connected to our laptops which are HP Probook 650 G2’s. We are getting constant Blue Screens from multiple teachers. They need to release a new driver asap. It would be nice to keep the computers on 1903 and I know downgrading them is a huge hassle. I wish they were more communicative on this issue and at least give us a update on a release date with a new driver and not leave so many in the dark.

  • #17062
    Cross
    Cross
    Participant

    Same problem here. Promethean, please COMMUNICATE!

    ANY news would be appreciated …. even bad news (well, not really… but you get the point)

  • #17063
    CJ Meyer
    CJ Meyer
    Participant

    They do have a beta fix but it is in very early stages of testing.  I have been testing this on around 6 computers with some pretty good luck.  Im giving it a few more days before i roll it out to more machines.  I am telling you all this so you know they are actively working on a fix for everyone but are concerned about the early beta release.  They do not want to create more problems for everyone.

    I am trying to give all my feedback and problems that arise as quick as i can to maybe help the final release of this driver.  Im frustrated also just as promethean is, but they are working on a fix for all of us.  Hope this helps….  the fix is coming i just dont know when.

     

    CJ

     

     

    • #17070
      Brandon10
      Brandon10
      Participant

      Is there a way you can provide me with this Beta Driver. I would at least like to get this installed because the other driver is really bad. And I can’t see the beta driver being worse.

  • #17071
    SUHSD TECH
    SUHSD TECH
    Participant

    I have two districts affected by this issue, here are the details:

    • Windows 10 1803-1809 (no issues)
    • Windows 10 1903 (Blue Screens)
    • HP ProDesk 600 G1, G2, G3 SFF all have the issue
    • I have various Promethean models (some are really old) and some are brand new. I believe only the older boards (that work better with the software anyways) are having the issue.
    • Here’s a memory dump from one of the machines: https://pastebin.com/iirZF1cd
    • #17072
      CJ Meyer
      CJ Meyer
      Participant

      Brandon what school district are you in? How could I get a hold of you?

    • #17073
      Brandon10
      Brandon10
      Participant

      I’m at mohawk Area School District. Can send me a link to the download at my email

       

  • #17074
    Jeremy Cherpeski
    Jeremy Cherpeski
    Participant

    I would like a link to the beta driver as well — I have too many computers that are causing too many problems because of the bad driver with windows 10 1903 .

     

     

  • #17075
    Chris Kuntzman
    Chris Kuntzman
    Participant

    I agree, we could all use the beta driver as well.   We have some teachers computers blue screening 3-4 times a day.

     

  • #17076
    CJ Meyer
    CJ Meyer
    Participant

    I am not going to provide the beta driver until they say it’s ok.  I do not want to cause more problems.  I will get a hold of you both to share my solutions.  If any one wants my help please provide your email address. Thanks!

    • #17078
      Chris Kuntzman
      Chris Kuntzman
      Participant

      Sorry, I didn’t mean to say you needed to share it,   I believe Promethean should be saying something and providing it as a option to “test” or to use as a temporary fix, until they have a solution for it.

      They should have a something on their support site, saying they do not recommend people upgrade to Windows 10 1903.  I am currently on their main support site, and nothing is said about it.

       

    • #17079
      SUHSD TECH
      SUHSD TECH
      Participant

      This.

      A banner across the “ActivDriver” page or a warning would have helped. When I was determining to allow Windows 10 1903 I checked Promethean’s site and saw nothing, and had a machine I looked at and didn’t run into the issue. Now that both of my school districts are upgraded, I’m not rolling them back. There is no security loss with 1803-1903 as they are still supported by Microsoft, but it is still a major pain to roll back for one vendor.

      A beta driver made publicly available even with a disclaimer is okay!

       

       

  • #17080

    Hi All,

    Whilst I appreciate this is a frustrating issue, we still need time to ensure that we get the correct solution in place. The recent Windows 10 1903 changes have impacted our ActivDriver when used with our legacy ActivBoards.

    The BETA version mentioned above is being sent to selected users as a closed BETA and is not for general distribution at this time.

    In order to get the BETA driver working correctly, users may be required to perform some extra steps, which are outside of the normal driver installation and initialisation hence why this is a closed BETA at present.

    It’s worth noting that not all users that have upgraded to Windows 10 build 1903 are seeing this issue, and earlier versions of Windows 10 appear to be unaffected; which is forming part of our investigation.

    We will update you all when we get some more concrete timelines based on the above.

     

  • #17101
    Matt Snead
    Matt Snead
    Participant

    We are having this problem at our district as well.  This is a real mess.  We just rolled out new laptops to all of our teachers and it’s causing us extreme headaches.

    Has anyone tried rolling the driver back and had any success?  We were previously using v5.11.7 before upgrading to the latest for this rollout.  We did this in part because that driver is from 2015 but also because we recently purchased some Titanium ActivPanels that we needed to support.

    We did roll back one machine to 5.11.7 today and we didn’t have any crashes but it was something we tried late in the day and haven’t had a chance to really vet it.  So it could have just been luck so far.

  • #17105
    E. H.
    E. H.
    Participant

    There’s no way to roll back here. We started a fresh image with 1903. Then after thorough testing this image was being rolled out to all machines.

    We couldn’t seen any problems, because an ActivPanel is connected to the PC which held the image.

    Then after trying to calibrate the ActivBoards every machine reproduciblely went away after 10 – 30 seconds with a bluescreen.

    Thanks …

  • #17282
    shannonwalker
    shannonwalker
    Participant

    Morning all,

    After reading through the posts, there was a Windows 10 1903 Cumulative Update released on August 30, 2019.  I am wondering if anyone can confirm if they are still experiencing issues with the activdriver and this update?  https://support.microsoft.com/en-ca/help/4512941/windows-10-update-kb4512941

    I see a lot of comments about 1903 but there’s a lot of updates after 1903 was pushed out.

    This update does address some issues with video and touch capabilities.

    [Edit:  I should probably add that in our division, we have 100, 300, 500, and newer boards.)

    Thanks in advance for your input!

     

     

  • #17284
    Jeremy Cherpeski
    Jeremy Cherpeski
    Participant

    I can confirm that the update (kb4512941) doesn’t resolve the issue.

  • #17285
    Matt Snead
    Matt Snead
    Participant

    Rolling back the driver to v5.11.7 also does not stop the crashing.

  • #17288
    Cross
    Cross
    Participant

    Any updates on this issue Promethean? Many people are now testing the BETA driver i guess? Keep communicating about the progress please.  We too need to keep answering the questions from our users on a daily basis.

    We’re also a bit in the dark here about an ETA. I know.. it’s difficult, but it would be frustrating to take drastic measures (rollback all machines) to keep our users happy only to see the driver released the day after.

     

  • #17396
  • #17409
    Michael Janke
    Michael Janke
    Participant

    Hi,

    thanks! I was able to successfully test the beta driver.
    I also could deploy the driver via GPO and without disabling signed drivers. Therefore I added the Certificate as Trusted publishers also via GPO.

    Best regards Michael Janke

  • #17448
    Nick Jacobe
    Nick Jacobe
    Participant

    We are having the same issue in our District. It is limited to HP computers at this time. 1903 seems to be the issue as well. We have uninstalled and reinstalled the ActivDriver and checked all of the hardware tests, and OS Tests recommended by HP. All of the system drivers are up to date and windows updates are up to date as of today as well.

     

    We have generic computer from a company called bytespeed and they are not having the issues….. yet… they have 1903 deployed to them.

     

    I hope this gets fixed soon, this is a huge issue.

  • #17477
    Evan Sullivan
    Evan Sullivan
    Participant

    Hello all!

    Our district is having the same issue with 1903 and ActivDrivers.  Per the post above I was able to download the beta drivers.

    When trying to deploy either the MSI or EXE the deploy fails with Error 1603 but I can install them manually.  Anyone else able to silently deploy them?  I did try and uninstall first but get the same result

     

    Thanks!

    • #17481
      Nick Jacobe
      Nick Jacobe
      Participant

      Evan,

      I am able to push it silently via our end point management tool. Below is my command line:

      msiexec.exe /i “ActivDriver_5_18_16_x64.msi” /qn ALLUSERS=2

      Installs without an issue. FYI we used the 64bit driver so you might need to change it to match your file type.

      Forgot to mention we are deploying the Promethean Ltd cert out via GPO to the computers before we do the install. Maybe that is why it’s failing.

    • #17483
      Evan Sullivan
      Evan Sullivan
      Participant

      I am using the default MSI parameters of “msiexec.exe /i “ActivDriver_5_18_16_x64.msi” ALLUSERS=1 /qn /norestart”

      Someone else says it’s working for them too.  Not sure what’s going on, on our end.  Thanks

    • #17486
      Evan Sullivan
      Evan Sullivan
      Participant

      Exporting the drivers cert and importing it before install works.  Thanks for any help!

    • #17759
      stephenlawJSRHS
      stephenlawJSRHS
      Participant

      We are knee deep in this issue and it is getting worse. Our laptops have updated more than 10 days ago to 1903 so we can’t roll them back. Trying the beta driver with no joy. I think it is related to driver signing. Would someone explain, this is new to me, host get and deploy a Promethean Ltd cert please? If I can get this to work on a few laptops, I have a roadmap to a temporary fix. Thanks. /SRL

    • #17787

      Hi Stephen,

      I would recommend seeing the post here which helps to provide an update to this issue:

      1st Generation, 2nd Generation, AB100, AB300, AB500 ActivBoards – BSoD with Windows 10 update 1903 BETA ActivDriver

       

      Thanks

      Adam

      Promethean Support

  • #17494
    henriksen
    henriksen
    Participant

    Are they planning on rolling out an updated version by the end of the week or should we just assume to proceed with the Beta Driver going forward?

  • #17672
    Matt Lucas
    Matt Lucas
    Participant

    Error still occurring:

     

    Fault bucket AV_activhidsermini!RtlStringCbPrintfW, type 0
    Event Name: BlueScreen
    Response: Not available
    Cab Id: 3c70d71c-8854-432c-a650-dd20eaa53bcc

    Problem signature:
    P1: a
    P2: eb126360a0
    P3: 2
    P4: 0
    P5: fffff8045c027926
    P6: 10_0_18362
    P7: 0_0
    P8: 256_1
    P9:
    P10:

    Attached files:
    \\?\C:\windows\Minidump\092519-5750-01.dmp
    \\?\C:\windows\TEMP\WER-10062-0.sysdata.xml
    \\?\C:\windows\MEMORY.DMP
    \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3B82.tmp.WERInternalMetadata.xml
    \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3B93.tmp.xml
    \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3BB1.tmp.csv
    \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3BB2.tmp.txt

    These files may be available here:
    \\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\Kernel_a_c5bfc8c024529a277799e6594fa39048cb824ff2_00000000_cab_66f9836b-c0df-49c0-9884-c0032a31415e

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: 6d582ca9-cda2-4478-89f2-0aa227400278
    Report Status: 268435456
    Hashed bucket:
    Cab Guid: 0

  • #17778
    henriksen
    henriksen
    Participant

    Are others still experiencing issues with the Blue Screens after the initial fix? I’m just curious. We are currently running out of ideas until the firmware is out. Any chance that the firmware update on these boards will be out sooner than later in October? Thanks.

    • #17780
      Jeremy Cherpeski
      Jeremy Cherpeski
      Participant

      That is odd — I haven’t had any issues since updating the driver.  Was having crashes daily before replacing the driver, and now we haven’t had any issues — I rolled it out last week to my sites with 1903 and immediately was told things are much better (no crashes).

  • #17813
    Patrick Shea
    Patrick Shea
    Participant

    I was wondering if there was any update on this? I have not seen anything posted since Sept. 26.

    Mark from Promethean posted a link, which basically state “Despite our best efforts, the change that has been introduced to Windows 10 build 1903 means we can no longer offer support for drivers or software for our 1st generation and 2nd generation ActivBoards when used with Windows 10 build 1903.”

    is that true?

    users can’t expect any work-arounds or fixes?

     

    • #17815

      Hi Patrick,

      Yes it’s true. Hence why it’s been posted.

      Users of up to 15 year old 1st and 2nd generation ActivBoards cannot have a firmware update, nor can Promethean release a signed ActivDriver for Windows 10 that would resolve the problem.

      Users of AB100, 300/ AB500 will be getting access to a firmware update which will resolve the problem.

      Technology limitations in the 1st and 2nd generation ActivBoards means we cannot develop a new firmware for these boards.

      Please see the latest on this here: https://community.prometheanworld.com/forums/topic/update-to-1st-generation-2nd-generation-ab100-ab300-ab500-bsod-windows-10-1903/

      Users of the 1st and 2nd generation ActivBoards can use the unsupported drivers as a work around, or not update to 1903.

      Thanks

  • #17860
    Brandon10
    Brandon10
    Participant

    I was wondering if the BETA driver released by Promethean on this issue is the last driver we will see regarding the blue screen for 2nd gen boards. Or are they planning on releasing one last official driver for the 2nd gen boards. If not I’ll roll this BETA driver across our district.

  • #17863

    Hi Brandon,

    Users of the 1st and 2nd generation ActivBoards cannot have a firmware update, nor can Promethean release a signed ActivDriver for Windows 10 that would resolve the problem.

    Technology limitations in the 1st and 2nd generation ActivBoards means we cannot develop a new firmware for these boards.

    Users of the 1st and 2nd generation ActivBoards can use the unsupported drivers (previously referred to as the BETA driver) as a work around, or not update to 1903.

    Thanks,
    Adam

You must be logged in to reply to this topic.