Accessories
Viewing 3 reply threads
  • Author
    Posts
    • #1280
      FRANCISCO SANTIAGOFRANCISCO SANTIAGO
      Participant

      Promethean Board pen stopped working. I unplugged devices, turned off pc and board for a day, tried to utilize the same pen on a different board in the building, borrowed another pen from another teacher but still to no avail. Please Help!?

    • #6517
      Anonymous
      Inactive

      Hi Francisco,

      Can you please provide us with the following information –

      – Model of ActivBoard
      – Driver version
      – Firmware version

      (both the driver and firmware can be found in your ActivManager control panel).

      The latest driver is 5.12 and can be downloaded from Support.PrometheanWorld.com (please disconnect the ActivBoard and remove your current driver first).

      We need to ensure you ActivBoard has a connection so that it will pick up the ActivPen, please ensure the LED if the top left hand corner of the ActivBoard is lit up and white/pink. If not please let us know what colour it is.

      As you have tested a known working ActivPen on this ActivBoard it rules out he ActivPen causing the issue.

      We look forward to hearing from you,

      Craig

    • #6518
      Anonymous
      Inactive

      I am having the same problem and I’m not sure where I will find the Model of my ActivBoard, Driver version, or Firmware version. It was working fine yesterday and then suddenly in the afternoon the pen would no longer communicate with the board. I can use my desktop computer, but not the pen. I’ve tried recalibrating and I hear a beep, but nothing comes up on the screen. The LED in top left corner is white and when I try to recalibrate it turns orange, but no bulls eye to calibrate. Please help, I use my board daily for most of the day.

    • #6519
      Anonymous
      Inactive

      Hi Mary,

      Thank you for your post.

      Please have a look at the link below which shows where to find the ActivManager that contains the firmware and driver information:

      https://support.prometheanworld.com/article/?kb=How-do-I-open-ActivManager

      Once you double-click on the ActivMgr icon, the ActivManager will appear on your system tray near the time and date.
      Thank you

      Miguel
      Promethean Technical Support

Viewing 3 reply threads
  • You must be logged in to reply to this topic.