ActivInspire e Linux 16.04

MozartinoMozartino Post: 2
Salve a tutti.

Noto che questa azienda investe tanto in prodotti e pubblicità ma vorrei che si dedicasse del tempo anche alla compatibilità con sistemi operativi open source perché tante scuole italiane stanno andando in quella direzione. Se non erro le ultime release dei software disponibili non sono al passo con le versioni correnti di Linux (16.04) e questo potrebbe comportare un diverso orientamento degli acquisti per la scuola.

Posso avere notizie in merito? Spero di non leggere nuovamente gli stessi messaggi che per qualche anno hanno inutilmente preannunciato versioni compatibili.

Cordiali saluti da un docente della scuola italiana.
«1

Risposte

  • GbianciaGbiancia Post: 1
    Sottoscrivo pienamente. Ho dei pc, nella mia scuola, in cui ho ancora installato ubuntu 12.04 per far girare activinspire, il cui supporto termina ad aprile 2017. E poi?
    Un'alternativa che mi è venuta in mente è quella di installare solo gli actidriver (sembra sia possibile dai vecchi repository) e poi usare open sankoré. Per ubuntu 14.04 avevo trovato il modo di installare activinspire forzando molte cose, ma il sistema appariva poco stabile, ed avevo postato il modo nel forum internazionale, copio ed incollo qui:
    In synaptic I add the repository for activinspire 12.04 precise:



    deb http://activsoftware.co.uk/linux/repos/ubuntu precise oss non-oss

    close synaptic without update.

    Then, in a terminal:

    wget http://www.activsoftware.co.uk/linux/repos/Promethean.asc
    sudo apt-key add Promethean.asc

    I don't know if it's really necessary:
    sudo apt-get install gcc-multilib



    Now install the whole ia32-lib instead, try the following order:

    sudo -i
    cd /etc/apt/sources.list.d
    echo "deb http://old-releases.ubuntu.com/ubuntu/ raring main restricted universe multiverse" >ia32-libs-raring.list
    apt-get update
    apt-get install ia32-libs

    PS: In this way, you can install ia32-libs. However, we add the source of 13.04 instead, so, there may be some problem unknown。After install ia32-libs, I recommend you to remove the ia32-libs-raring.list in /etc/apt/sources.list.d, and do sudo apt-get update. I have do this with sudo nautilus command.

    Now I had to ceate the /usr/local/lib32 directory
    sudo mkdir /usr/local/lib32
    Then I had to correct the name of the libjpeg32 library (from 8 to 8.0.2) and thus the suggested command becomes
    sudo ln -s /usr/lib/i386-linux-gnu/libjpeg.so.8.0.2 /usr/local/lib32/libjpeg.so.62

    At the end:
    sudo apt-get install activinspire

    That's all!

    http://www1.prometheanplanet.com/it/server.php?show=nav.20743

    http://community.prometheanplanet.com/en/forums/products/f/27/p/15787/37494.aspx#37494

    http://stackoverflow.com/questions/23182765/how-to-install-ia32-libs-in-ubuntu-14-04-lts
  • MozartinoMozartino Post: 2
    Gbiancia hai provato questa procedura?
    Come installare il software Activinspire per lim Promethean su Ubuntu 14.04
    
    1 - Installare il pacchetto libjpeg62 da terminale:
         
         "sudo apt-get install libjpeg62"
    per i sistemi a 64 bit:
    sudo apt-get install libjpeg62:i386
    
    2 - Aggiungere i repository: aprire 'Software e aggiornamenti --> Altro software --> aggiungi' quindi inserire:
         
         "deb http://activsoftware.co.uk/linux/repos/ubuntu trusty oss non-oss"
    
    Per le versioni diverse da 14.04 modificare il nome in codice della versione (sostituire la parola "trusty") con quello corrispondente: 13.04 raring - 13.10 saucy - 14.10 utopic - 15.04 vivid - 15.10 - wily (fino alla 14.04 funziona sicuramente, per le successive non ho mai provato...)
    
    3 - Importare la chiave di autenticazione da terminale:
        
         "wget http://www.activsoftware.co.uk/linux/repos/Promethean.asc && sudo apt-key add Promethean.asc"
    
    4 - Sempre da terminale:
    
         "sudo apt-get update"
    
         "sudo apt-get install activinspire activtools activdriver"
    
    Il software può essere installato anche dal Software Center
  • Buongiorno Mozartino e Gbianca,

    Benvenuti al nostro forum.

    L'elemento software che permette di interagire con un ActivPanel o ActivBoard è l'ActivDriver.
    Installando ActivDriver su una macchina con Ubuntu sarà possibile interagire con lo schermo della LIM.
    ActivDriver è disponibile per tutte le versioni di Ubuntu che siano di supporto esteso (long supported).

    Le istruzioni per Ubuntu 12.04 sono comprese nel processo di installazione di ActivInspire ( https://support.prometheanworld.com/download/activinspire.html )

    Per installare ActivDriver per le altre versioni sarà necessario installare tutti gli elementi per la versione appropriata in ordine alfabetico (id est: ActivAid, ActivDriver, ActivRelay, ActivTools). Si tratta di elementi autoinstallanti.

    Per Ubuntu 16.04 64 bit:

    https://promethean.box.com/v/ActivAid1604-64

    https://promethean.box.com/v/ActivDriver1604-64

    https://promethean.box.com/v/ActivRelay1604-64

    https://promethean.box.com/v/ActivTools1604-64

    Per Ubuntu 16.04 32 bit (i nomi non sono visibili nei link, ma sono in ordine:ActivAid, ActivDriver, ActivRelay, ActivTools) :

    https://promethean.box.com/s/oo30yt67o3kycmflpyinnddy6zgzkuzm

    https://promethean.box.com/s/db9r1ewivpx9766q4j48d6xh1siwjzk0

    https://promethean.box.com/s/eyvqot2ia6pmgu6wwdyzkn2gu51be487

    https://promethean.box.com/s/9se4zk4k89smbvtvd1za9w889bsnhxpi


    Per Ubuntu 14.04 32 bit:

    https://promethean.box.com/v/activaid5-13-12-0i386

    https://promethean.box.com/v/activdriver5-13-12-0i386

    https://promethean.box.com/v/activrelay3-1-7-0i386

    https://promethean.box.com/v/activtools5-13-12-0i386


    Per Ubuntu 14.04 64:

    https://promethean.box.com/v/ActivAid

    https://promethean.box.com/v/ActivDriver

    https://promethean.box.com/v/ActivRelay

    https://promethean.box.com/v/ActivTools

    Qualora aveste bisogno di ActivDriver per versioni precedenti alla 12.04 posso certamente cercare di reperirli, ma potrebbe volerci un po di tempo.

    Una volta installato il driver, l'hardware Promethean sarà riconosciuto, e si potrà interagire con lo schermo utilizzando qualsiasi programma in grado di funzionare sul computer.

    Per quanto riguarda ActivInspire, effettivamente la ultima versione effettivamente supportata è per Ubuntu 12.04 32 bit.

    Non possiamo escludere che, in futuro, sia sviluppata e resa disponibile una versione compatibile con release di Ubuntu successive, ma al momento non abbiamo date precise.
    Inoltre, il mercato punta decisamente verso piattaforme multimediali online, come il nostro Classflow ( https://classflow.com/ ) piuttosto che programmi a se stanti installati localmente.

    Spero di essere stato di aiuto.

    Un saluto,

    Riccardo

    Supporto Tecnico di Promethean



















  • albyalby Post: 1
    buonasera,

    avrei bisogno dei driver per ubuntu 14.04 64 bit, ma clikkando sul link nno funzionano.
    Potete gentilmente ripristinarli? o vi sono versioni nuove ad.esempio per la 1604 che possono essere utilizzati?
    grazie per il vostro supporto.

    Albano
  • Buongiorno Albano,

    Benvenuto sul forum di Promethean.

    Ho provato ad utilizare I link nel post precedente, e sono in grado di scaricare ed aprire tutti e 4 I file per la versione 14.04.
    Cosa, esattamente, va storto? Non viene rediretto alla pagina?

    Per comodità, le lascio nuovamente I link:


    https://promethean.box.com/v/ActivAid51421-1404-64bit


    https://promethean.box.com/v/ActivDriver51421-1404-64bit


    https://promethean.box.com/v/ActivRelay323-1404-64bit


    https://promethean.box.com/v/ActivTools51421-1404-64bit


    Le ricordo che vanno installati nell'ordine qui sopra.


    Un salute,

    Riccardo

    Il Supporto Tecnico di Promethean
  • clauritaclaurita Post: 8
    Salve,
    i link indicati per il download dei driver per linux non sono più attivi.
    C'è modo di avere accesso ai nuovi active drivers?
    Grazie
  • Buongiorno Claurita,

    Benvenuto al forum di Promethean.

    I link delle versioni a 32 bit (sia per la 16.04 che la 14.04) sembra si aprano senza problemi.
    Le lascio i link per le versioni a 64 bit:

    UBUNTU 14.04

    https://promethean.box.com/v/ActivAid51421-1404-64bit


    https://promethean.box.com/v/ActivDriver51421-1404-64bit


    https://promethean.box.com/v/ActivRelay323-1404-64bit


    https://promethean.box.com/v/ActivTools51421-1404-64bit


    Le ricordo che vanno installati nell'ordine qui sopra.


    UBUNTU 16.04

    https://promethean.box.com/v/ActivAid51421-1604-64bit

    https://promethean.box.com/v/ActivDriver51421-1604-64bit

    https://promethean.box.com/v/ActivRelay323-1604-64bit

    https://promethean.box.com/v/ActivTools51421-1604-64bit

    Anche in questo caso, le ricordo che i file sono autoinstallanti e vanno lanciati nell'ordine indicato.

    Un saluti,

    Riccardo

    IL Supporto Tecnico di Promethean

  • Buon giorno, sarebbe possibile postare i link aggiornati per ubuntu 16.04 32bit? I link precedenti non funzionano più. Grazie!
  • Gentile Livio,

    Benvenuto al forum di Promethean.

    Le lascio i link per i driver per la versione 16.04 32 bit.
    Come negli altri casi, i file vanno eseguiti nell'ordine seguente:

    https://promethean.box.com/v/ActivAid51421-1604-32bit

    https://promethean.box.com/v/ActivDriver51421-1604-32bit

    https://promethean.box.com/v/ActivRelay323-1604-32bit

    https://promethean.box.com/v/ActivTools51421-1604-32bit

    Non esiti a scriverci ancora qualora avesse altre domande.

    Saluti,

    Riccardo

    Il Supporto Tecnico di Promethean

  • beppebeppe Post: 2
    Grazie Riccardo con i link che hai postato sopra anch'io sono riuscito a far riconoscere e funzionare una LIM Promethean ActiveBoard ad un notebook con Lubuntu. Per gestirla utilizziamo Open Sankore e, per ora, funziona benissimo. Vorrei approfittare della tua disponibilità per chiederti se e come è possibile risolvere il problema dell'immagine proiettata che è un pò sbilenca. Preciso che ho già provato a farla ritornare regolare con le varie opzioni del menu proiettore senza riuscirci. E' un problema di posizione "fisica" del proiettore mi pare. Ti allego un paio di immagini della videata sbilenca. Grazie per l'attenzione. Beppe
  • Buongiorno Beppe,

    Benvenuto al nostro forum.
    In effetti si direbbe che sia un problema di assetto fisico del proiettore.
    Bisognerebbe raddrizzarlo, e avvicinarlo leggermente in modo da coprire la intera superficie della LIM.
    Non si tratta, in genere, di una operazione complessa, ma qualora non se la sentisse le suggerisco di contattare il servizio che ha installato la LIM, sono certo che saranno lieti di aiutarla.

    Un saluto,

    Riccardo

    Il Supporto Tecnico di Promethean

  • beppebeppe Post: 2
    Grazie Riccardo. Eventualmente faccio una prova e poi, semmai, chiedo l'intervento della ditta installatrice la quale, purtroppo, ha la sede piuttosto lontano. Dove posso trovare un manuale tecnico di installazione della Lim e del proiettore? il modello della LIm è Active Board ABV378pro. Grazie Ancora
  • Buongiorno Beppe,

    Il nostro Portale di Supporto fornisce una grande quantità di informazioni sui nostri prodotti.
    In particolare, per questo modello di ActivBoard, le suggerisco di visionare i manuali che trova in questa pagina: 

    https://support.prometheanworld.com/it/product/activboard-300-pro

    Spero di essere stato di aiuto.

    Non esiti a contattarci nuovamente per qualsiasi domanda.

    Saluti,

    Riccardo

    Il Supporto Tecnico di Promethean
  • Mozartino74Mozartino74 Post: 10
    Buonasera.
    Avevo installato ActivInspire su un notebook con Ubuntu 16.04.3 LTS Release ma quando avviavo il software si bloccava l'immagine iniziale e non andava avanti.
    Allora ho provato su un pc sperando che il risultato fosse diverso ma purtroppo dopo un riavvio non è presente nemmeno l'icona in alto a destra per la calibrazione.

    Ho creato un report (activaid.tar.gz) sperando possa essere di aiuto.

    Attendo vostre osservazioni in merito e saluto cordialmente.

  • Salve Mozartino74,

    Grazie per il suo post.
    Ha provato a installare ActivInspire sia da Gestare di pacchetti che da terminale, secondo le istruzioni in questo articolo?
    https://support.prometheanworld.com/it/article/?kb=1017
    In caso il problema continuasse a sussistere, invieremo il suo report (grazie di averlo inviato) ai nostri sviluppatori.
    Potrebbe tuttavia volerci un poco prima che si ottenga una risposta, visto che dovranno innanzitutto riprodurre il problema.

    Grazie in anticipo per la collaborazione.

    Un saluto,

    Riccardo

    Il Supporto Tecnico di Promethean
  • MarcoMarco Post: 2
    Salve Riccardo,
    sono Marco e insieme a Mozartino74 sto tentando di installare il software per gestire la lim su Ubuntu 16.04.03 64bit senza successo.

    Le operazione che abbiamo eseguito dopo aver installato e aggiornato Ubuntu 16.04.03 64bit sono nella sequenza:
      • aggiornamento pacchetti apt-get update
      • iinstallazione da repository di activ-meta-it
    I problemi che riscontriamo sono:
    1. Blocco di activinspire subito dopo il lancio
    2. Non riconoscimento della penna per interagire con la lavagna
    Il problema non e' stato ancora risolto per cui direi di coinvolgere il team di sviluppatori.

    Un modo semplice per risolvere il problema potrebbe essere quello di mettere a disposizione da parte del team di sviluppo una macchina virtuale con Ubuntu 16.04.03 64bit funzionante e la sequenza esatta delle operazioni che sono state eseguite per configurarla.
    Oppure un playbook di ansible con la sequenza delle operazioni eseguite ( io sto usando questo link https://gitlab.com/app4school/lim/blob/master/active.yml.)

    Per quanto riguarda invece la versione di Ubuntu 18.04 che uscira'  a breve quando e' previsto il rilascio del software?

    Saluti,
    Marco
  • Buongiorno Marco,

    Benvenuto al nostro forum.

    Le suggerisco di provare, nell'ordine, a seguire le istruzioni nei seguenti articoli:


    https://support.prometheanworld.com/it/article/?kb=1623 (per installare ActivDriver e quindi regolare la interazione tra LIM e computer)

    https://support.prometheanworld.com/it/article/?kb=1017 (per ActivInspire, uno dei nostri software di presentazione)

    In questo modo riesce ad installare ed eseguire correttamente tutto?

    Per quanto riguardsa la prossima LTS di Ubuntu, non abbiamo notizie sui tempi.
    Il sistema stesso non è ancora disponibile, pertanto il lavoro degli sviluppatori non ha ancora potuto avere inizio.

    Saluti,

    Riccardo

    Il Supporto Tecnico di Promethean
  • MarcoMarco Post: 2
    Ho eseguito tutto nell'ordine suggerito ma ho sempre gli stessi problemi.
    • Blocco di activinspire subito dopo il lancio
    • Non riconoscimento della penna per interagire con la lavagna
    Ho provato sia su un portatile che su un PC fisso in cui era installata la versione per Ubuntu 14.04 (funzionante) ma il comportamento e' identico.


  • Salve Marco,

    Grazie per la informazione.
    Ho tentato di riprodurre il problema installando ActivDriver e ActivInspire su computer con la distribuzione ufficiale di Ubuntu 14.04, ma senza esito.
    Non ho ancora provato ad eseguire ActivInspire ma la installazione di ActivDriver procede senza problemi e l'hardware Promethean viene riconosciuto quando collegato.
    A questo punto direi che risulterà necessario esaminare le specifiche delle macchine coinvolte, ed è meglio procedere attraverso richieste di supporto dirette piuttosto che attraverso il nostro forum.
    Le suggerisco di raggiungerci per telefono oppure attraverso email, troverà le indicazione necessarie in questa pagina: https://support.prometheanworld.com/it/contact/

    Cordiali saluti,

    Riccardo

    Il Supporto Tecnico di Promethean

  • Mozartino74Mozartino74 Post: 10
    Ho tentato di riprodurre il problema installando ActivDriver e ActivInspire su computer con la distribuzione ufficiale di Ubuntu 14.04, ma senza esito.
    Gentile Riccardo, la problematica evidenziata si riferisce all'installazione su computer con la distribuzione ufficiale di Ubuntu 16.04

    Cordiali saluti.
  • Salve Mozartino,

    Si lo avevo immaginato.
    Tuttavia non sono stato in grado di riprodurre il problema con il driver.
    Intendo dire che sulla mia macchina si installa correttamente e risponde come previsto.
    Per questo motivo suggerivo di aprire una richiesta di supporto e proseguire individualmente, visto che avremo certamente bisogno di informazioni sensibili su sistema operativo e macchina.

    Qualora dovesse essere un problema, potremo continuare sul forum, anche se non si tratta di un mezzo ideale per arrivare a fondo della questione.

    Cordiali saluti,

    Riccardo

    Il Supporto Tecnico di Promethean
  • robertoroberto Post: 1
    salve a tutti ho la versione 18.04 e vorrei installare activinspire ma non ci riesco. qualcuno può aiutarmi?



  • Buongiorno Roberto,

    La ringraziamo per aver postato nel nostro Forum.

    Al momento non è ancora disponibile la versione di ActivInspire per Ubuntu 18.04.

    Può fare riferimento ai requisiti minimi di sistema su questo link:
    https://support.prometheanworld.com/it/content/activinspire-requisiti-minimi-del-computer.

    Non essendo prevista una data specifica per il rilascio, quando la  versione compatibile sarà  disponibile, verrà pubblicato un aggiornamento nella Community di Promethan:
    https://community.prometheanworld.com/it

    Restiamo a disposizione qualora avesse bisogno di maggior informazioni.

    Cordiali saluti

    Pasquina
    Supporto Tecnico Promethean
  • pippopippo Post: 5
    Mozartino74 ha detto:
    Ho tentato di riprodurre il problema installando ActivDriver e ActivInspire su computer con la distribuzione ufficiale di Ubuntu 14.04, ma senza esito.
    Gentile Riccardo, la problematica evidenziata si riferisce all'installazione su computer con la distribuzione ufficiale di Ubuntu 16.04

    Cordiali saluti.
    Buonasera, pure io sono nella stessa situazione, blocco all'avvio con la 16.04. Non ci sono novità?  :(.....
  • Buongiorno Pippo,

    Benvenuto al forum di Promethean.
    A partire da Settembre esiste una versione di Ubuntu 16.04, segnatamente la 16.04.5, che ancora una volta cambia il kernel rendendo incompatibili gran parte dei programmi sviluppati sino ad ora per tale piattaforma, incluso il nostro ActivDriver.
    Qualora stesse usando questa versione di Ubuntu, le suggerisco di tornare ad una versione precedente e provare nuovamente ad installare ActivDriver seguendo le istruzioni in questo articolo: https://support.prometheanworld.com/it/article/?kb=1623

    Non esiti a ricontattarci qualora avesse domande.

    Cordiali saluti,
    Riccardo

    Il Supporto Tecnico di Promethean

  • pippopippo Post: 5
    Buongiorno Pippo,

    Benvenuto al forum di Promethean.
    A partire da Settembre esiste una versione di Ubuntu 16.04, segnatamente la 16.04.5, che ancora una volta cambia il kernel rendendo incompatibili gran parte dei programmi sviluppati sino ad ora per tale piattaforma, incluso il nostro ActivDriver.
    Qualora stesse usando questa versione di Ubuntu, le suggerisco di tornare ad una versione precedente e provare nuovamente ad installare ActivDriver seguendo le istruzioni in questo articolo: https://support.prometheanworld.com/it/article/?kb=1623

    Non esiti a ricontattarci qualora avesse domande.

    Cordiali saluti,
    Riccardo

    Il Supporto Tecnico di Promethean

    Grazie, proverò con una macchina di test... Per natale, noi tutti qui, vorremmo i sorgenti dei driver, così non vi stressiamo più ad ogni uscita di versione e saremmo più invogliati a scegliervi di nuovo per i futuri acquisti scolastici... :)
  • pippopippo Post: 5
    Buongiorno Pippo,

    Benvenuto al forum di Promethean.
    A partire da Settembre esiste una versione di Ubuntu 16.04, segnatamente la 16.04.5, che ancora una volta cambia il kernel rendendo incompatibili gran parte dei programmi sviluppati sino ad ora per tale piattaforma, incluso il nostro ActivDriver.
    Qualora stesse usando questa versione di Ubuntu, le suggerisco di tornare ad una versione precedente e provare nuovamente ad installare ActivDriver seguendo le istruzioni in questo articolo: https://support.prometheanworld.com/it/article/?kb=1623

    Non esiti a ricontattarci qualora avesse domande.

    Cordiali saluti,
    Riccardo

    Il Supporto Tecnico di Promethean


    Ho rifatto la procedura indicata con la 16.4.1 ma senza successo...
  • pippopippo Post: 5
    Salve Mozartino,

    Si lo avevo immaginato.
    Tuttavia non sono stato in grado di riprodurre il problema con il driver.
    Intendo dire che sulla mia macchina si installa correttamente e risponde come previsto.

    Per questo motivo suggerivo di aprire una richiesta di supporto e proseguire individualmente, visto che avremo certamente bisogno di informazioni sensibili su sistema operativo e macchina.

    Qualora dovesse essere un problema, potremo continuare sul forum, anche se non si tratta di un mezzo ideale per arrivare a fondo della questione.

    Cordiali saluti,

    Riccardo

    Il Supporto Tecnico di Promethean
    Buongiorno, sa dirmi quale versione della distribuzione (16.04.x) e quale kernel ha utilizzato per ottenere il risultato citato?
    Grazie.
  • Buongiorno Pippo,

    LA versione con la quale ho provato è Ubuntu 16.04.3, ma qualsiasi versione precedente alla 16.04.5 dovrebbe funzionare, compresa quella utilizzata da lei.
    Che tipo di errore riceve?

    Grazie per la collaborazione.

    Cordiali saluti,
    Riccardo

    Supporto Tecnico di Promethean
  • pippopippo Post: 5
    Buongiorno e grazie per la risposta: l'errore, quando ad esempio lancio da shell activcalibrate.sh è:
    .......
    ...Promethean: Open lock
    ...Promethan; Global locking...

    e la penna non funziona...
    nel menù in altro a destra non compare nulla...

    Qualche suggerimento?
    Grazie

«1
Accedi oppure Registrati per commentare.