Forum Replies Created

Viewing 4 reply threads
  • Author
    Posts
    • #18903
      Brian CaugheyBrian Caughey
      Participant

      Hi Adam,

      Finally got bulb verified as being good so went deeper into fault. Stripped projector down to expose the thermal switch which seemed to click into position when pressed with a screwdriver. Next was the tangential fan which cools the bulb it was completly bunged up with hard packed dust, cleaned this out and reassembled ……. O joy! after switching on the lamp worked.

      Projector now back in Reception class of local primary school.

      Thank You for help,

      Brian.

    • #18873
      Brian CaugheyBrian Caughey
      Participant

      Thank you Adam.

      Best Regards,

      Brian

    • #18871
      Brian CaugheyBrian Caughey
      Participant

      Hi Adam,

      Installed a known good bulb from another working projector and still get the same sequence of tryig to power up, so still no light output.

      Any ideas?

      Best Regards

      Brian.

      PS How do I open a new ‘post’?

    • #18834
      Brian CaugheyBrian Caughey
      Participant

      Thank You Adam will have to try another bulb though at the cost of a new one I will have to find some way of testing replacement bulb.

      Regards

      Brian

    • #18821
      Brian CaugheyBrian Caughey
      Participant

      Hi Adam,

      Thank you for prompt reply.

      New bulb was fitted originally because there was no light whatsoever (sorry my choice of words in original post ‘light loss’ sounds the bulb went dim), it was swapped back when new bulb did not cure problem. Both bulbs have same fault……..bulb completely dead.

      Is it commom for new bulbs to be faulty? The actual bulb in new assembly is Philips UHP 200/150W. Is there any way to verify if our new bulb is faulty other than having another OHP of same model?

      Had a closer look at faulty bulb seems like it exploded as reflector is cracked, front lens all clouded and a wire I noticed wrapped around the new bulb glass has gone/disappeared from original lamp.

      Just tried projector without any lamp fitted and get the same sequence of attempting to power up.

      Regards,

      Brian

       

Viewing 4 reply threads