|

387Pro Board suddenly erratic

rgcowiergcowie Posts: 3
edited on October 4 2017 in Interactive Whiteboards
We are a school with many 387Pro boards, we use Win10 64-bit.  One board has developed USB issues after being perfectly stable for a long time. 

We swapped out known working USB extenders and computers from other boards & classrooms, but cannot stay connected to this one board. 

We tried various versions of ActivDriver/ActivManager (5.11 through newest 5.16), all have the same behavior.

Here are the symptoms, we may get any of these:

1.  Quick flashes of red flame, no connection chime
2.  Red flame then green, then reset back to red flame and repeat cycle
3.  Stable connection but usage or calibration gives message "no board".
4.  Continuous connect and disconnect with Windows chimes
5.  Connection drops out when HDMI video cable is connected to computer
6.  Computer reports "Micronas USB headset" as the connected device when board is plugged in.

Just looking for advice on how to troubleshoot or identify the board electronics, as it seems that's the issue.  Thanks in advance for any help!

Answers

  • rgcowiergcowie Posts: 3
    Reports now that another board has started doing this, in the adjacent room.
  • Hi rgcowie,

    Thank you for your post.

    It seems that the issue you described is the same as the one found in the article below.
    Please have a look at the link below and complete all recommended steps and let us know the outcome.

    https://support.prometheanworld.com/article/?kb=1016

    Thank you

    Miguel
    Promethean Technical Support

  • rgcowiergcowie Posts: 3
    On the second board, we were able to trace the event log.  After applying Windows Updates for Office,  Windows attempted to update the Photo and Skype apps (these are Metro and not desktop).  Before doing this, it made an adjustment to the power plan, and within a few minutes, the Promethean board spontaneously disconnected (surprise removal).  This left the USB drivers in a corrupted state, and the computer froze at restart and had to be powered down.  After this, the board would not connect again with the extender in place.

    So we disconnected the board and in the device manager, showed hidden devices, and then uninstalled all the USB devices that were greyed out (including Promethean).  Then we moved the computer temporarily close enough to the board to avoid the extender.  On connection with the board's native USB cable, the drivers installed and the board worked.  Then we moved the computer back in place with the extender, and it now seems to be working well again.

    The initial installation of the board drivers appears to work better without the extender (using a direct connection), but then after that, routine operation seems to be ok with the extender.  We are using the wall-plate CAT6 extenders from Liberty Cable, in general they have worked much better than the powered extender cables we had previously.

    On the first board, we tried the USB 2.0 hub but found it could not stay connected either (even without the Promethean board), so that computer has separate USB issues.  At one point it had a BSOD upon connection.  We will try to replace the motherboard, if that fails we will do a clean install of Windows.  I'll report back with results.

    We have a third issue with a laptop, that one would connect to the board but disconnect when the HDMI cable was plugged in.  That appears to be a separate issue as well, unrelated to the two above.  No clue on that one yet.

    All these behaviors are very confusing until you tease them apart.  My guess is the second board issue also occurred on the first board, but then with all the things that were tried to get it to work, USB may have been shorted or damaged.
     
  • Thank you for keeping us up to date on this issue, @rgcowie.   If we can provide any further advice on troubleshooting the ActivBoards or other Promethean hardware, please let us know.
Sign In or Register to comment.