Clicker stopped working in ActivInspire but OK in other programs.

Hello, I have a clicker in use with one of the boards at my school and it has suddenly stopped working with ActivInspire. The clicker, however, is still functioning as normal in other programs such as PowerPoint. Could anyone please help me out with any suggestions as to what could be the cause for this and help me getting the clicker back to working how it previously had. Thank you.


  • Hi Welshbrum,

    On the clicker does it look like the item in this ActivRemote user guide?  Here is the link to the user guide https://support.prometheanworld.com/files/public/pdfs/ActivRemote+QSG+TP-1750+v1.pdf.  If that is your clicker you must have the page turn effects turned on in ActivInspire, you can find that under view page turn effect.
    If you are still having a problem, please provide your ActivDriver version, ActivInspire version and the OS version of your computer.

    Thank you,

  • Hi Pam, thank you very much for getting back to me. No that is not the clciker we are using. In this instance just a simple presentation clicker is being used, not an ActivRemote as you've indicated or the ActivExpression handsets we use. The presentation click in use simply replicates a mouse click or page up/down. As mentioned it was previously working with no issues whatsoever, but has now ceased working with ActivInspire.

    The versions we are on as requested: ActivDriver 5.11.7, ActivInspire 2.8.66693 and Windows 10 Enterprise 2015 LTSB (64-bit).
  • Hello welshbrum, 

    Thank you for providing us with further information. Please check to if the driver or the software that is used for the presentation clicker needs to be updated. You can also check if disabling "enable turn gestures and enable touch pan and zoom in ActivInpire will also get the presentation clicker to respond once again. 

    To locate the settings, click on File  - Setting - Dual Mode ActivBoards. You will see both options at the bottom of the screen 

    Once you have changed those settings close and re-open ActivInspire once again to check if the presentation clicker is functioning once again within ActivInspire. 

    Kind Regards, 
    Promethean Technical Support
Sign In or Register to comment.