|

touch not working

 Have an ActiveConnect G series connected to an ActivePanel Touch(APT2-70). Touch stopped working. Was working and I had to disconnect the HDMI cable. When I plugged the HDMI back in the touch no longer works.  What do I do to reset it?

Answers

  • ...and I have disconnected the power to power cycle. Did not fix the problem. The lock screen is visible. My USB keyboard/mouse work, but the touchscreen does not.
  • Martha PrometheanMartha Promethean Posts: 61 mod
    edited on April 4 2018

    Hello Davep10144,

    Please ensure that when you disconnected the HDMI cable, the USB cable did not happen to come lose? HDMI is only responsible for handling the video, the USB cable is what allows touch functionality.

    Also please make sure that the USB connection that goes from the Panel to the ActivConnect is not in the USB OTG port.

    Kind regards,
    Martha
    Promethean Technical Support


  • I did some troubleshooting. I borrowed a different Activeconnect G and connected it to my board and still no response...also tried 2 different USB cables. The problem is with the Active Panel, is there a driver update or reset?
  • Hello Davep10144,

    In that case, what we would recommend is trying to flash the Bezel Firmware on the panel itself. This will typically assist with any touch issues that you may encounter.

    The following article will assist you on how to perform this update: https://support.prometheanworld.com/article/?kb=1160

    Please let us know the results, we look forward to assisting you in this matter further.

    Kind regards,
    Martha
    Promethean Technical Support

Sign In or Register to comment.