ActivBoard en Ubuntu 16.04 - Errores al calibrar

Buenos días,

Tras instalar ActivInspire y ActivDriver en Ubuntu 16.04 con kernel 4.4.0-21, he intentado ejecutar ActivCalibrate pero no surge ningún efecto.
Desde la terminal, ejecutndo el comando "activcalibrate" recibo los siguientes errores:

[email protected]:~$ activcalibrate
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Gui.so.5: version `Qt_5' not found (required by activcalibrate)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5.6' not found (required by activcalibrate)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5' not found (required by activcalibrate)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5_PRIVATE_API' not found (required by /usr/lib/i386-linux-gnu/libQt5Widgets.so.5)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5.6' not found (required by /usr/lib/i386-linux-gnu/libQt5Widgets.so.5)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5' not found (required by /usr/lib/i386-linux-gnu/libQt5Widgets.so.5)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Gui.so.5: version `Qt_5_PRIVATE_API' not found (required by /usr/lib/i386-linux-gnu/libQt5Widgets.so.5)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Gui.so.5: version `Qt_5' not found (required by /usr/lib/i386-linux-gnu/libQt5Widgets.so.5)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5.6' not found (required by /usr/lib/i386-linux-gnu/libQt5Network.so.5)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5' not found (required by /usr/lib/i386-linux-gnu/libQt5Network.so.5)
activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5_PRIVATE_API' not found (required by /usr/lib/i386-linux-gnu/libQt5Network.so.5)

¿Existe alguna solución a éste problema? Es una distribución recién instalada, y NO es 16.04.5, sino 16.04. Lo comento porque he leído que aún no hay compatibilidad con ésta última versión LTS.

Un saludo y muchas gracias.

Respuestas

  • Riccardo PrometheanRiccardo Promethean Publicaciones: 198 mod
    Hola jonatan

    Bienvenido a nuestro foro.
    ¿Qué artículo están siguiendo?
    Es bastante normal que haya errores de la tipología "not found" cuando está instalado, ¿se ha reiniciado el ordenador?
    Este artículo proporciona más información sobre este tema: https://support.prometheanworld.com/article/?kb=1623

    No dude en contactarnos si tiene alguna pregunta.

    Saludos,
    Riccardo

    Soporte Técnico Promethean
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Buenos días,

    He seguido los artículos 1623 y 1017 para realizar la instalación.

    Un saludo.
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Hola jonatan

    Bienvenido a nuestro foro.
    ¿Qué artículo están siguiendo?
    Es bastante normal que haya errores de la tipología "not found" cuando está instalado, ¿se ha reiniciado el ordenador?
    Este artículo proporciona más información sobre este tema: https://support.prometheanworld.com/article/?kb=1623

    No dude en contactarnos si tiene alguna pregunta.

    Saludos,
    Riccardo

    Soporte Técnico Promethean
    Buenos días,

    He seguido los artículos 1623 y 1017 para realizar la instalación.

    Un saludo.
  • Riccardo PrometheanRiccardo Promethean Publicaciones: 198 mod
    editado 7 de diciembre
    Hola Jonatan

    Perfecto, el artículo correcto es efectivamente el 1623.
    ¿Cuál es la versión de Ubuntu 16.04 que usan?
    Leo que no es la 16.04.5, esta versión, disponible a partir de septiembre, utiliza un kenrel diferente, que no es compatible con nuestro ActivDriver.
    ¿Cual es el Kernel que utilizan?.

    No dude en contactarnos si tiene alguna pregunta.

    Saludos,
    Riccardo

    Soporte Técnico Promethean
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    editado 7 de diciembre
    Hola Jonatan

    Perfecto, el artículo correcto es efectivamente el 1623.
    ¿Cuál es la versión de Ubuntu 16.04 que usan?
    Leo que no es la 16.04.5, esta versión, disponible a partir de septiembre, utiliza un kenrel diferente, que no es compatible con nuestro ActivDriver.
    ¿Cual es el Kernel que utilizan?.

    No dude en contactarnos si tiene alguna pregunta.

    Saludos,
    Riccardo

    Soporte Técnico Promethean
    Buenos días,

    Las pruebas se han realizado sobre un Ubuntu 16.04.
    Adjunto captura con información y errores.


    ¿Podría proporcionar un listado de kernel compatibles?

    Un saludo.
  • Riccardo PrometheanRiccardo Promethean Publicaciones: 198 mod
    editado 20 de noviembre
    Buenos días Jonatan,

    Gracias por su respuesta.
    Al parecer, en el ordenador falta este elemento: https://wiki.qt.io/Install_Qt_5_on_Ubuntu

    Por favor, intente instalarlo y, después, reinstale ActivDriver.
    ¿Sigue sin funcionar?

    Saludos cordiales,
    Riccardo

    Soporte técnico de Promethean
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Buenos días,

    Tras realizar la instalación sugerida en el equipo de pruebas, el resultado al ejecutar activcalibrate es el siguiente:

    [email protected]:~$ activcalibrate
    activcalibrate: /usr/lib/i386-linux-gnu/libQt5Network.so.5: version `Qt_5' not found (required by activcalibrate)
    activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Gui.so.5: version `Qt_5' not found (required by activcalibrate)
    activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5.6' not found (required by activcalibrate)
    activcalibrate: /usr/lib/i386-linux-gnu/sse2/libQt5Core.so.5: version `Qt_5' not found (required by activcalibrate)
    activcalibrate: /usr/lib/i386-linux-gnu/libQt5Widgets.so.5: version `Qt_5' not found (required by activcalibrate)

    Necesito una solución un poco urgente, ya que queremos implementar el soporte para PDI's Promethean en nuestro sistema. Del mismo modo sería prácticamente un requisito que Promethean tuviera soporte para Ubuntu 16.04.5, que es la versión más común.

    Un saludo.
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Buenos días Jonatan,

    Gracias por su respuesta.
    Al parecer, en el ordenador falta este elemento: https://wiki.qt.io/Install_Qt_5_on_Ubuntu

    Por favor, intente instalarlo y, después, reinstale ActivDriver.
    ¿Sigue sin funcionar?

    Saludos cordiales,
    Riccardo

    Soporte técnico de Promethean
    Comentar también que el instalador de Qt en Ubuntu de 64 bits falla y no termina de instalar.

    Un saludo.
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Buenos días de nuevo,

    Aparentemente he conseguido solventar el problema de librerías. El siguiente error que recibo cuando ejecuto activcalibrate es el siguiente:

    This application failed to start because it could not find or load the Qt platform plugin "xcb"
    in "".

    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, wayland-egl, wayland, xcb.

    Reinstalling the application may fix this problem.
    Abortado (`core' generado)
    Si conseguimos solventar éste problema, yo mismo realizaré un manual con el proceso completo.
    A la espera de su respuesta.

    Un saludo.


  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Buenos días Jonatan,

    Gracias por su respuesta.
    Al parecer, en el ordenador falta este elemento: https://wiki.qt.io/Install_Qt_5_on_Ubuntu

    Por favor, intente instalarlo y, después, reinstale ActivDriver.
    ¿Sigue sin funcionar?

    Saludos cordiales,
    Riccardo

    Soporte técnico de Promethean
    Buenos días,

    Sigo a la espera de soporte por parte de Promethean.
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Buenos días,

    ¿Están trabajando en el problema? ¿Tienen algún avance?

    Un saludo.
  • Adam H PrometheanAdam H Promethean Publicaciones: 385 admin
    Hola jonatansanchez1, gracias por sus aportes.

    Estamos en el proceso de discutir este tema en interno.

    Le mantendremos informado lo más antes posible.

    Cordialmente,
    Adam
  • Adam H PrometheanAdam H Promethean Publicaciones: 385 admin
    Hola jonatansanchez1,

    ¿El ordenador que tiene es de 64-bits? Si es así, necesitaría instalar los elementos QT en 32-bit dado que ActivInspire y ActivDriver usan la biblioteca compartida de 32-bit.

    Cordialmente,
    Adam 
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Hola jonatansanchez1,

    ¿El ordenador que tiene es de 64-bits? Si es así, necesitaría instalar los elementos QT en 32-bit dado que ActivInspire y ActivDriver usan la biblioteca compartida de 32-bit.

    Cordialmente,
    Adam 
    Buenos días,

    He solventado el problema duplicando unas librerías, tengo el proceso anotado para cuando esté finalizado.

    El problema actual es que la pizarra no es detectada hasta pasados unos minutos. Cuando abro ActivInspire, se queda iniciando hasta que aparece el mensaje "Se ha detectado 1 dispositivo", el cual parece tomarse un tiempo aleatorio.
    Hasta que ese cartel no aparece, activcalibrate no funciona y ActivInspire no arranca.

    ¿Les aporta algo de luz ésta información? ¿Sabrían decirme qué hace de disparador para que la pizarra sea detectada en un momento dado? Sabiendo ésto podríamos forzarlo y tenerlo controlado.

    Un saludo.
  • Riccardo PrometheanRiccardo Promethean Publicaciones: 198 mod
    editado 4 de diciembre
    Hola jonatansanchez1,

    Gracias por su respuesta.

    Si ActivDriver arranca la ActivBoard tendría que detectarse en segundos.

    ¿Si desenchufan el cable USB y vuelven a enchufar se detecta inmediatamente?

    ¿Como es la conexión USB?

    Si el cable no llega directo del ordenador a la PDI (osea si pasa a través de controladoras, extensiones de cableado o Hub) este puede impactar sobre el funcionamiento correcto del driver. 

    En este caso, por favor, intente conectando la PDI al ordenador a través de un cable USB que no sea mas largo de 5 metros.

    ¿El problema se soluciona?

    Saludos,
    Riccardo

    Soporte Técnico Promethean
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Hola jonatansanchez1,

    Gracias por su respuesta.

    Si ActivDriver arranca la ActivBoard tendría que detectarse en segundos.

    ¿Si desenchufan el cable USB y vuelven a enchufar se detecta inmediatamente?

    ¿Como es la conexión USB?

    Si el cable no llega directo del ordenador a la PDI (osea si pasa a través de controladoras, extensiones de cableado o Hub) este puede impactar sobre el funcionamiento correcto del driver. 

    En este caso, por favor, intente conectando la PDI al ordenador a través de un cable USB que no sea mas largo de 5 metros.

    ¿El problema se soluciona?

    Saludos,
    Riccardo

    Soporte Técnico Promethean
    Buenos días,

    La conexión es directa. La PDI es inmediatamente detectada cuando desconectas y conectas el USB, no así cuando inicias el equipo sin sacar el USB.
    Esto no es una solución, pero tal vez les sirva de pista.

    Un saludo.
  • Adam H PrometheanAdam H Promethean Publicaciones: 385 admin
    Hola Jonatan,

    Gracias por su respuesta. ¿Sería posible confirmar la versión del ActivDriver instalada y la versión del firmware que aparecen en el panel de control de ActivManager?

    Cordialmente,
    Adam
  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Hola Jonatan,

    Gracias por su respuesta. ¿Sería posible confirmar la versión del ActivDriver instalada y la versión del firmware que aparecen en el panel de control de ActivManager?

    Cordialmente,
    Adam
    Buenos días,

    La versión de ActivDriver es 5.17.14-0, la que queda instalada tras seguir los pasos del artículo 1623.
    La versión del firmware es v8.04 compilación 4.

    Un saludo.
  • Riccardo PrometheanRiccardo Promethean Publicaciones: 198 mod
    Buenos días Jonatan,
    ActivDriver esta actualizado, el firmware no.
    No reconozco esta versión.
    ¿Cual es su modelo de ActivBoard?

    Por favor, intente actualizar el firmware de la PDI siguiendo los pasos en este articulo: https://support.prometheanworld.com/es/article/?kb=1038
    Nota: para llevar a cabo de la actualización del fimware tendrá que utilizar un ordenador con Windows.
    Después de la actualización, podrán utilizar los con Ubuntu también.

    Si desean actualizar el firmware mediante un ordenador con Ubuntu, siga este articulo: https://support.prometheanworld.com/es/article/?kb=1166

    Por favor, déjenos saber si el problema sigue después de la actualización del firmware.

    Saludos,
    Riccardo

    Soporte Técnico Promethean

  • jonatansanchez1jonatansanchez1 Publicaciones: 12
    Buenos días Jonatan,
    ActivDriver esta actualizado, el firmware no.
    No reconozco esta versión.
    ¿Cual es su modelo de ActivBoard?

    Por favor, intente actualizar el firmware de la PDI siguiendo los pasos en este articulo: https://support.prometheanworld.com/es/article/?kb=1038
    Nota: para llevar a cabo de la actualización del fimware tendrá que utilizar un ordenador con Windows.
    Después de la actualización, podrán utilizar los con Ubuntu también.

    Si desean actualizar el firmware mediante un ordenador con Ubuntu, siga este articulo: https://support.prometheanworld.com/es/article/?kb=1166

    Por favor, déjenos saber si el problema sigue después de la actualización del firmware.

    Saludos,
    Riccardo

    Soporte Técnico Promethean

    ¿Podría facilitar el enlace exacto del firmware que debería utilizar?

    Un saludo.
Accede o Regístrate para comentar.