Student Response Devices
Viewing 6 reply threads
  • Author
    Posts
    • #2475
      Anonymous
      Inactive

      I have recently updated Activexpression Handsets. It has been successful on most but I now have 3 that will not turn on and only give a blank screen and 2 that will switch on briefly but display a rectangle in the middle of the screen. Is their a solution for this?

    • #10122
      Anonymous
      Inactive

      Hi AlphaPapa,

      Thank you for posting on the Support Community.

      The ActivExpression devices you have upgraded, are these the version 1 (with the phone like keyboard)? 

      I would recommend removing the battery of the devices and try inserting new batteries to see if this helps.

      If you are able to see to apply the firmware upgrade again, you could also try this. Although the devices which do not show anything on screen you may not be able to apply the update again.

      I hope this information helps.

      Kind regards,
      Adam
      Promethean Technical Support

    • #10123
      Anonymous
      Inactive

      I had a similar situation and the attached article turned out to be the fix.

      https://support.prometheanworld.com/article/?kb=1215

    • #18735
      Markus DuchatschMarkus Duchatsch
      Participant

      Hi,

      I have the same problem like anonymous. I tried to upgrade from 9.01 to 9.02 B39 EU. I followed exactly the tutotial and have new batteries in the Activexpression 1. Now I only see an empty rectangle when I swith on. Is there any solution for that?

      Thanks

      Markus

    • #18736

      Hi Markus,

      Is the rectangle filling up at all?

      If you restart the upgrade process from the ActivManager and then try to do this from your device, is this working?

       

      Thanks

      Adam

      Promethean Support

    • #18737
      Markus DuchatschMarkus Duchatsch
      Participant

      Hi Adam,
      I got an hint instead selecting the kernel I selected the firmware. Here V9.02B41 EU. I started the upgrade process with the PC application and then switched on the repond device. Now the progress bar filled up until the upgrade was complpeted. I could now switch on the device again an celect the menu. So everything seems ok now.

      Thanks
      Markus

    • #18738

      Hi Markus,

      Thanks for the update, glad to hear that this is now working for you.

      Kind regards,
      Adam

      Promethean Technical Support

Viewing 6 reply threads
  • You must be logged in to reply to this topic.