Interactive Whiteboards
Viewing 49 reply threads
  • Author
    Posts
    • #18148
      Justin StokesJustin Stokes
      Participant

      Has anyone updated the firmware on their boards yet? I have updated three different 378Pro boards and now none of them respond to touch. Using multiple computers. They show up in device manager as HID devices as they are now supposed to. Touch doesn’t work, and activmanager no longer detects them when connected. Flame is white and flashes blue to register a touch, but nothing registering on the computer.

      Have opened a support ticket but just curious what others have experienced.

    • #18149
      Joe ParkJoe Park
      Participant

      I have the same exact issue as well with the 378Pro.

      Caveat:  I did do the update over a USB cable that was longer than 3m and was connected to a USB booster.

      The board had been working fine in Windows 1803.  Promethean tech support suggested connecting to the board with a computer using a USB cable 3m or shorter.  Haven’t tried it yet, but I will post the result when I do.

    • #18165
      Craig PrometheanCraig Promethean
      Moderator

      Hello Both,

      Can I ask which firmware you have upgraded too?

      You will need to upgrade using a 3m USB cable with a direct connection.

      You will also need the latest Promethean driver installed. I have provided a link below:

      ActivDriver

      Please let us know the results.

      Kind regards,

      Craig

      Promethean Technical Support

      home

       

    • #18172
      Joe ParkJoe Park
      Participant

      I tried the 378pro again with a USB cable that was shorter than 3m.  Same result.  However, I was running a laptop with the latest version of ActivDriver, but it was Windows 1803!  🙁

      I haven’t gotten a chance to get that board hooked up to an 1903 Windows laptop yet.

    • #18173
      Justin StokesJustin Stokes
      Participant

      @ Craig, this is for 8.12, the firmware that was released on 10/31 to fix the BSOD issue.

      @Joe, all of mine were running 1903 which is why I was eager to install the upgrade asap 🙁

    • #18177

      Hello,

      Please remember when using a USB 3.0 chipset, 3m is the maximum length. Sometimes using a USB hub booster can help get a stable connection.

      Adem Couper

      Promethean Technical Support

    • #18182
      Joe ParkJoe Park
      Participant

      So today:

      • Uninstalled and reinstalled the latest ActivDriver
      • Connected to the board with a USB cable > 3m.
      • Used a laptop with all updates and Windows 1903 with USB 2.0.

      Got this result with our ABV378PRO, Serial C0912310354:

      • Flame went through it’s color routine and ended on white.
      • Pen does not work; When touching the board, flame turns blue.  Mouse cursor does not move.
      • I am unable to try to do the firmware update again; in ActivManager, there is no information about the connection to the board other than USB in the ‘Connection’ column.

      Two days ago, I did do the firmware update in article 1779, but it was over a 16ft USB cable with a booster.   After the firmware update, that’s when our issues started.

      I went through all the steps in the 1779 article re: selecting ‘tablet’ in ActivManager.

      I went through the steps for changing the Windows Tablet PC settings with no success; the pen did not work for the calibration screen that popped up during these steps.

       

    • #18187

      Hi Joe,

       

      The flame being white is correct and that it turns blue when a pen touches the surface is also correct.

      Can you please confirm what firmware is currently installed on the ActivBoard?

      You do no need to go to the “connections” tab as this for legacy serial connections and not USB.

      Even using a USB 2.0 port if it has a USB 3.0 chipset this will sometimes takes precedence.

      When attempting a firmware update we recommend only doing it with a short cable which gives you a stable connection.

      Thank you.

      Adem

      Promethean Technical Support

       

      • #18198
        Joe ParkJoe Park
        Participant

        I am unable to view the firmware version; there is no information in the ActivManager window other that ‘USB’ under the ‘Connections’ column.  Also, the board takes around 7 minutes to connect to ActivManager, but even then the connection info just says ‘USB’ under the ‘Connections’ column.

      • #18199
        Justin StokesJustin Stokes
        Participant

        I’ve got an appointment for a remote session with Promethean support tomorrow morning. Will update this thread with any info I get.

    • #18206
      Justin StokesJustin Stokes
      Participant

      Ok, Had a session with Promethean support. You have to boot the boards in a very specific order after the firmware upgrade basically every time a computer is connected to it.

       

      Power off amplifier, either the button on side or unplug power.
      Disconnect USB (this also provides power)
      Reconnect USB (flame in corner will cycle colors and settle solid white when finished booting)
      Power amplifier back on.

      • #18249
        CrossCross
        Participant

        Dear Promethean.. is this expected behaviour? We’re also experiencing this problem on several boards after the firmware upgrade.

        Although following the boot procedure does work to fix the connection … i can’t say our teachers are happy about it being necessary…

    • #18251
      Kyle BisignaniKyle Bisignani
      Participant

      So just to follow up with everyone, I can confirm independently of Justin’s work with Promethean Support the issue is in fact related to the 300 Pro models (could be 500 Pro too, but I don’t have any of those) with the powered speakers.  When connecting a device (such as a laptop) to the board and the speakers are powered on, the flame indicates that everything is connected, but the pen does not register and the ActivManager shows a red X indicating no board is connected.

      Disconnecting the laptop from the board, powering off the speakers, then connecting the laptop back up, and finally turning on the speakers, resolves the issue.

      The support rep I spoke with didn’t really have any information on the issue just yet, so I can only hope this is just a simple driver update and not new firmware that has to be loaded onto the board.  Fact is, having to dock and turn on the speakers after the fact is probably better than the laptops restarting from a Windows BSoD.

      She did say to keep an eye here at the forums for an update from Promethean about the issue…

    • #18259

      Hi Cross, Kyle Bisignani

      Thanks for posting.

      From the issue that you have mention about the steps that you’ve followed from Justin Stokes, we think that you may have previously been on an older version of ActivBoard firmware prior to updating to the HID firmware.

      I would recommend rolling back your firmware to one listed on the article below and then updating to the HID firmware again:

      1779

      Please remember, after you’ve applied the HID firmware please follow these steps:

      -Power off the ActivBoard at the amplifier by pressing the On/Standby button. Ensure that the button is now red.
      -Disconnect the USB cable from the computer.
      -Reboot the computer.

      This should only be required the once.

       

      Thanks,

      Adam

      Promethean Support

    • #18270
      Kyle BisignaniKyle Bisignani
      Participant

      Yikes Adam! Yes, I’m certain the boards with issues certainly weren’t updated prior to loading the new HID firmware. Any special instructions to roll back, or is it as simple as installing the file in the article you linked?

    • #18273
      Jordan KasparekJordan Kasparek
      Participant

      I already posted this somewhere else but the solution here only fixes it until you unplug from the board again. I talked to Promethean support for over an hour yesterday and while we have found no permanent solution this is the solution I found to work best temporary:

      It seems that ActivManager freezes up when you plug in your laptop if the amp on the side is on, to fix this:

      • After you unplug your laptop from the board turn off the amp on the side (light should be red)
      • After you plug your laptop back into the board turn the amp back on (light should be green)

      This should stop ActivManager from freezing for the time being until it is permanently fixed

       

      • #18274
        CrossCross
        Participant

        Yep. I also told our users to make sure the AMP is off when they leave the classroom to prevent the issue from happening in the morning when they connect to the board.

        Adam, all our boards are 300 series 87″. I’m pretty sure they were all running 8.09 firmware prior to updating.

        I guess the only thing i didn’t quite do as you describe is the procedure after updating. I used my own laptop to walk from board to board to update them … obviously i did not reboot my laptop each time i updated a board…

        Is it even possible to have a firmware upgrade being only half a success? I thought these things either go well … or fail completely?

        I’ll try downgrading and upgrading again with some boards to see what happens.

      • #18309
        Kyle BisignaniKyle Bisignani
        Participant

        I mean as it stands right now, I’d rather have users keep their speakers off than have the laptops reboot 4 times a day…  Heck, I’ll just disconnect the speakers outright and give them desktop speakers if I have to.

    • #18278
      SUHSD TECHSUHSD TECH
      Participant

      Calibrating these boards post firmware update is a nightmare.

       

      • Windows 10 1903
      • Promethean 300/500 Series

      Can calibrate:

      • 1 monitor
      • 1 projector

      Cannot calibrate:

      • Multiple monitors regardless if using duplicate/extended mode
      • Multiple monitors with one display set to “disconnect this display”. While monitors and projectors are physically connected, I cannot calibrate.

      Even windows “Tablet” settings in the control panel cannot be setup as it won’t accept any input from the board. Once I remove a monitor, I can use both utilities without issue.

    • #18289

      Hi SUHSD TECH,
      You have a different issue than what has been reported by others. To help with your issue, per the instructions on Article 1779, did you set your ActivManager Control Panel to Tablet mode under the pens tab:

      Here is the extract from the article:

      b. Pen interaction in extended desktop will only work if ActivManager is set to Tablet mode.

      Open ActivManager’s Control Panel and click on the Pens tab.
      Under Pen Mode, select Tablet.
      Click Close.
      NB: You may need to configure Windows 10 to allow the Stylus input to work on your ActivBoard as the second screen. To do this, go to the
      Windows Control Panel, open Tablet PC Settings, then click Setup and follow the instructions on screen.

      This is due to the way Windows handles different input types (Mouse inputs, Stylus/Pen inputs, Touch inputs, etc.).
      Due to the limitations of Windows HID device drivers, mouse inputs cannot be used on a single extended screen only (e.g. the ActivBoard). Windows HID device drivers only allow Stylus and Touch inputs to control single extended screens.
      This is because Windows expects mouse events to span across all screens, not each individual screens separately, so pen interaction as Mouse input cannot work in extended desktop.

       

      For the Connectivity issues mentioned by Cross, Jordan Kasparek and Kyle Bisignani. Can you confirm that you have rolled back your firmware and then performed the HID firmware upgrade per the full article instructions listed here?

      Thanks

      Adam

      Promethean Support

      • #18351
        SUHSD TECHSUHSD TECH
        Participant

        Yes I’ve gone through the steps. Even if I set them to tablet mode, any form of extended desktop does not work. This is on either the 300 (grey) or 500 (dark grey) series boards. They all work for me in duplicated mode with one monitor, one projector.

      • #18364

        Hi,

        Have you tried to calibrate using the Windows Calibration Tool in Tablet PC Settings under Windows?

        Thanks

        Adam

        Promethean Support

    • #18322
      Kyle BisignaniKyle Bisignani
      Participant

      So I tried your steps @Adam-K-Promethean, upgrading the firmware to the previous latest firmware 8.10 for our 378 Pro boards, disconnected, rebooted,  reconnected, then repeated the steps for the 8.12 firmware.

       

      Unfortunately even after all that, if the powered speakers are on and I connect the laptop, the flame turns white, but the pen doesn’t work.  Disconnect the laptop from the board, power off the speakers, reconnect the laptop to the board, pen works.  Turn on speakers, pen still works.

       

      So… I’m going to update them anyway because this procedure at least allows the teachers to use their boards without the computers blue-screening and rebooting.  But I’m not sure what the next steps should be – should I report this to support again, or is it something that is already being looked at?  Maybe just needs an update to the driver?  Hopefully not a new firmware….

    • #18344

      Hi Kyle Bisignani,

      Thanks for the update and confirmation.

      We are still investigating this issue internally, however as a test, could you try and uninstall ActivDriver completely, following the instructions and see if the ActivPen still works and if you are required to repeat the same steps for the pen to work?

      Please follow the steps on the below link:

      1064

      Thanks

      Adam

      Promethean Support

    • #18391
      Michael LawrenceMichael Lawrence
      Participant

      I can confirm the same issues when upgrading our 378Pro boards to the latest firmware release (8.12).  We have upgraded and tested several 378Pros from 8.10 build 7 to 8.12. If you unplug the USB cable and plug it back in and the amp on the board is on (green light) the ActivBoard will never show up in ActivManager and pens do not work. If you unplug the USB cable, turn off the board amp (red light) and reconnect the USB cable it will connect every time (shows in ActivManager) and functions correctly. Once connected you can turn the amp back on without issue.  I have been able to replicate this issue every time on Windows 10 builds 1803 and 1903 with the latest ActivDriver installed (5.18.12).  I have uninstalled and reinstalled the ActivDriver but issue remains.  Problem only exists when board has new firmware.

      Since this changes the behavior our teachers are used too we are considering delaying our 1903 update push. We would rather not delay but we have hundreds of 378Pros and explaining the new connection  process is easier said than done.

    • #18424
      Joseph ShipleyJoseph Shipley
      Participant

      FYI,

      I’m also having the exact same issue as Michael Lawerence above.  I have resorted to just leaving the amp/speakers off and using my own speakers so that I don’t have the connection issue until a driver is updated, etc.

    • #18470
      John O'MahonyJohn O’Mahony
      Participant

      Hi Adam and all,

      I am having the same issue where teachers are using laptops with 378 Pro boards that I upgraded the firmware on to HID that are stored each afternoon. The firmware upgrade though not perfect perhaps  is a big improvement on the situation of having the computer constantly restarting a few weeks ago, sometimes maybe three times in the space of ten minutes. When connected next morning pens not working. The solution to disconnect USB, turn mains off at board, reconnect USB and wait for colours to cycle and finally power up boards again does work. However teachers have been using these boards for many years and are not accustomed to this procedure, if a solution can be found it would be very helpful and appreciated.

      Can I ask a question re the non supported driver for 2nd Generation Boards. Does Promethean recommend updating firmware on these boards as per Article 1391 https://support.prometheanworld.com/article/1391/ before installing the updated non supported driver?

      Thanks in anticipation.

      Regards,

      John.

    • #18476

      Hi John, Joseph, Michael,

      We are aware of this method for connecting and our hardware team are currently looking into this.

      For the 2nd Generation ActivBoards, this does not necessarily need the latest firmware applying to the ActivBoard prior to using the unsupported ActivDriver.

      Kind regards,
      Adam

      Promethean Support

    • #18526
      John O'MahonyJohn O’Mahony
      Participant

      Hi Adam,

      Thanks for your reply to my query above and sorry for the delay in getting back to you. I tried the non supported driver for the 2nd Generation ActivBoards on a board where I had previously updated firmware. It certainly has worked very well on the board I tried it on, teacher reports that so far issue of BSOD crashes resolved. I found that I didn’t have to disable Secure Boot on the bios of the particular HP laptop connected to this board which made the installation of the new driver a quick and painless procedure. I was wondering has anyone tried using the non supported driver on the newer  AB 100, AB 300 or AB 500 ActivBoard?. I am tempted to try it on the next board where the laptop updates to Windows 10 Build 1903 as with the other Promethean HID firmware update process I have found there are three stages to the installation process:

      •  ActivDriver has first to be updated, computer has to be rebooted
      • Firmware has to be updated from downloaded file, have to log in with an administrator account and follow procedures outlined carefully
      • HID firmware update while connected to the internet
      • Change of behaviour that teachers/pupils are accustomed to – turning off power to the board before connecting USB, once USB connected and colours cycle, turn on power otherwise driver doesn’t load properly and pens not working
      • Double clicking with pen not working as before whereby users (teacher/pupil) must go to the computer to browse folders, launch applications etc.

      I am interested in other views on the above or if anyone knows about progress on a solution for these issues with HID firmware from Promethean.

      Thanks in anticipation.

      John.

    • #18624
      Hendrik HeirmanHendrik Heirman
      Participant

      Is there still no definitive fix available for this problem?

      I have 12 boards which I upgraded to the last firmware, computers al have the latest windows updates and the most recent activdriver.

      The fix with switching the amp off before connecting works most of the times but not allways. Teachers are complaining on a daily basis…

      Can Promethean please give an estimated date for a definitive fix?

    • #18640
      Wendy PrometheanWendy
      Moderator

      Hi all,

      Thank you for all the feedback regarding this. We appreciate the update has caused a lot of issues for a lot of Windows users and are working with our Software development team to see what our options are in regards to the ActivDriver and Firmware for the ActivBoard 300 and 500. The good news is that at least the boards can be used with the new Firmware, we just need some time to iron out these connection issues some people are seeing.

      We will definitely keep you posted!

      Thank you!

       

      Wendy

      Promethean Technical Support

       

      • #18768
        Adam VeatchAdam Veatch
        Participant

        Any updates on this issue, Wendy?

      • #18774

        Hi Adam,

        We do not have any further updates at the moment on this.
        We’ll add your request to the development teams ticket.

        Many thanks,

        Adam

        Promethean Technical Support

    • #18697
      Adam VeatchAdam Veatch
      Participant

      Technical support should probably include this issue as a possible side effect in your 1779 article. We’ve begun upgrading firmware as well and started running into issues a couple days afterwards once computers have restarted.

    • #18918
      Adam VeatchAdam Veatch
      Participant

      Just bumping this again to ask if any further developments have been made on this issue.

    • #18922
      Kyle StovallKyle Stovall
      Participant

      We are still having these issues in our schools, although the only boards that seem to be giving a BSOD are the one’s connected via ActivHub.

      Was wondering if this could be part of the issue?

      The upgrade seems to have worked on the boards connected via USB though. The freezing has not become an issue as of yet, since it can easily be mitigated.

    • #18951
      stechgirlstechgirl
      Participant

      I would like to express my concerns on this issue as well.  Currently the choice is have the computer restart and blue screen or the teacher looses use of their speakers.  The whole point of an ActivBoard series 300 board is for the board AND speakers.  I am still waiting on a resolution.

      I also think this should be added as an effect in your support article about updating the firmware.

    • #18973
      Wendy PrometheanWendy
      Moderator

      Hi Stechgirl,

      Just to clarify:  the ActivBoard 300 Series speakers can still be used after the PC and Activboard are connected, Teacher are fine to turn the Amp on after this step.

      Our developers are aware of all the issues that have been reported here and we will keep updating them with every new report and information we get.

      Thank you,

       

      Kind regards,

      Wendy

      Promethean Technical Support

      home

    • #18979
      Adam VeatchAdam Veatch
      Participant

      Thanks for the update, Wendy! Just for some clarification, though, that can be incredibly disruptive for teachers that are not blessed with newer machines. Between pending Windows Updates and/or older machines, that full restart and making sure the board’s amp is turned off before they do so can be a 10 minute ordeal. When you’re talking about a 80 minute block, telling them to jettison up to 12% of their teaching time in a class for a reboot isn’t feasible. Especially if it’s potentially going to need to be done multiple times a day.

    • #18985
      stechgirlstechgirl
      Participant

      Yes, so it is correct the amp will work if you perform all the steps correctly and in the right order, but then as soon as you shut down or restart you have to do it all over again.  It is difficult for teachers to find the time to perform all the steps and do their job.  Again, it would be great if the ActivBoards worked correctly.

    • #18989
      SUHSD TECHSUHSD TECH
      Participant

      We ended up having to replace any 3rd generation boards with the amps, the rest work okay. At least we didn’t have many with the amps. To deal with the 2nd gen boards dying, I’ve so far removed or replaced 22 Promethean Boards. Crazy! I don’t think Promethean understands that generally speaking most teachers aren’t big into technology as far as problem solving is concerned, and that it just gets put on the IT staff as a perpetual nightmare, and it ends up eating class time. As a result, we’re trying to transition staff away from the boards in general.

    • #19001
      Stephen LedbetterStephen Ledbetter
      Participant

      As with everyone else in this thread, we are quite fed up. Our teachers are most certainly not tech people. It is not there job to troubleshoot or go through a 10-20 minute process just to be able to use their boards. Some classes such as ESL and SPED classes rely on these boards to make learning more hands on and fun. I reverse engineered the problem, from what I have found there isn’t a way to fix this. The system driver USBccgp.sys was changed in windows 10 1903. The way it handles requests for single devices with multiple drivers was changed. If I were a programmer I would at least try and make a work around; instead we are met with excuses, fixes that don’t actually work, and made to wait for a fix for several months. This has got to stop, we need a fix, not an excuse but a solution. Maybe that solution is a brand new board replacement at no charge considering what we have all been through, or maybe that fix is a new patch or driver. I truly don’t know, i do know this needs to end.

    • #19002
      Justin StokesJustin Stokes
      Participant

      How long does a company need to support a discontinued product? These boards are 10 years old at this point. And the process is not 10-20 minutes. Turn off amp, unplug USB, plug back in, turn on amp. Takes 2 minutes at most and should only need to be done once a day when first connecting their pc.

      Alternate option is to downgrade board firmware, and use the beta activdriver (5.18.16) that was originally posted as a workaround. Since this issue has cropped up that has been my go to solution as it avoids the whole scenario.

      • #19003
        Stephen LedbetterStephen Ledbetter
        Participant

        You’re right, if all the teachers K-12 could control the kids, learn how to do it, remember how to do it, keep up with lesson plans, and do my job they could do that in two minutes. Thing is, its my job to fix it, not work around it, fix it. Teachers are paid to teach not troubleshoot, as I stated previously. Where are you getting this downgrade file? It’s not on the downloads page? I have 5 machines around me right now. With another 20-30 others i have to get done with various issues. I don’t have time to go look through a thousand posts to find it. Believe it or not us techies had to get an education to do what we do, teachers got an education to teach, not to deal with finicky tech.

      • #19004
        Justin StokesJustin Stokes
        Participant

        Look, it seems like you might be having a rough day so I’m going to help you out.

        Here is the link to the driver:

        https://promethean.box.com/s/kwce3i3z4syhicm0788541hcivrpnpyb

        And here is the board firmware:

        1038

         

        Best of luck to you.

    • #19017
      Hendrik HeirmanHendrik Heirman
      Participant

      I wonder if Promethean realizes how many people are affected by this problem??

      On 31 October a firmware update was provided to solve the issue with the blue screen. Blue screen was fixed, but then problems started with the USB connection.

      Now allready 3 (!!) months have passed and still there is no definitive solution for this problem. Not even an esstimated date for a fix…

      Should we start thinking about getting rid of our Promethean whiteboards and changing to a different brand? The only problem is that most schools just don’t have the funds to swap whiteboards just like that… But I’m going to think long and hard what to buy next if this problem isn’t fixed!

      Promethean used to be a reliable partner, now, day by day, I’m just getting more frustrated…

      Please Prometean, give priority to this problem and provide a fix asap!

    • #19071

      Hi,

      To follow up, our teams are investigating this issue, however a work around has been provided in the meanwhile to use.

      This is to turn the amplifier off when not in use. When you are ready to use the ActivBoard and are connected to the computer, then turn on your amplifier. This will allow for the connection to be made for the pens to be interactive.

      We will continue to monitor this issue and provide an update in due course.

      Kind regards,

      Adam

      Promethean Support

       

    • #19076
      stechgirlstechgirl
      Participant

      Just turning off the amp doesn’t work these steps must be followed for the pens to work:

      1. disconnect the computer

      2. turn off the amp

      3.Wait for light to turn completely  out in the corner

      4.Restart computer

      5.Leave amp off

      6.Reconnect the computer

      7.Use ActivManager on the computer and do calibration

      The amp could be turned on at this point, but as soon as the computer is restarted all the steps from 5-7 must be followed for it to connect.

      • #19077
        SUHSD TECHSUHSD TECH
        Participant

        Yep and I have teachers that can’t use extended desktop as they just can’t seem to figure it out. As stechgirl has stated a solution that’s about 7 steps too long for them, it goes to show why after 6 months of school a working board at this point doesn’t seem too unreasonable. Tomorrow I replace my last unit.

    • #19078
      Michael LawrenceMichael Lawrence
      Participant

      For us step 4 (restarting the computer) wasn’t necessary, just connecting the computer back up after the amp was turned off worked.

      We are replacing our remaining ActivBoards this summer with ActivPanels but in the meantime we have just installed the unsupported ActivDriver on our machines connected to these boards to avoid these connection issues.  So far that has worked perfectly for us.

      https://community.prometheanworld.com/forums/topic/update-to-1st-generation-2nd-generation-ab100-ab300-ab500-bsod-windows-10-1903/

      • #19079
        stechgirlstechgirl
        Participant

        That driver is for 1st and 2nd generation boards.  My issue is mainly with ActivBoard 300 series.  Is that driver helping with that series?

    • #19080
      Michael LawrenceMichael Lawrence
      Participant

      stechgirl, yes, we have installed the unsupported driver on machines connected to 300 and 500 series boards.  I just checked and it looks like we haven’t installed it on as many as I thought.  We have delayed the 1903 update until the boards are replaced this summer but are installing this driver if the machine gets updated to 1903 before that time.

      Just to be sure I would give it a try first on a machine that connects to a 300 series.

    • #19081
      SUHSD TECHSUHSD TECH
      Participant

      If you’re going that route, did you upgrade the firmware to the most recent version plus the unsupported driver? As a general rule, we won’t allow the compromised driver for production (no just Promethean). Ironically only the Promethean boards have had this issue as far as we’re aware, and that’s why we opted instead for replacing them.

    • #19082
      Michael LawrenceMichael Lawrence
      Participant

      We did not upgrade the firmware on the boards using the modified ActivDriver.  We are using the modified driver so that we don’t have the connection issues with upgrading the firmware.

    • #19121
      stechgirlstechgirl
      Participant

      I tried the driver with a ActivBoard that the firmware was updated on.  It didn’t help.  I am going to try it on some that I haven’t updated the firmware on.

    • #19131

      Hi stechgirl,

      Can you confirm which ActivDriver version you are using with your 300 series ActivBoards?

      If you are using 5.18.18, please manually uninstall following the instructions on the link below and restart:

      1064

      Once restarted, please download the 5.18.12 ActivDriver from the link below:

      https://promethean.box.com/s/rf6ri2hewgeqwc3xab2teqyc4dl6k5qs

      Kind regards,
      Adam

      Promethean Support

    • #19192
      Stephen LedbetterStephen Ledbetter
      Participant

      After much deliberation and failed fixes we have decided to go to a wired solution until we can purchase more Dell touch monitors for all schools. The problem with the work around is having to disable not only driver signature enforcement but also secure boot. It just makes the attack vector too large for our security needs. As a security focused group this can not be allowed. While i do understand that the 378 pros have been out of warranty and Promethean’s main focus for sometime i can’t understand why it meant so little to the company to fix issues for its users. We are thankful for the time that they did function properly but will not be purchasing anymore products from this manufacturer. If any other users have a way around turning secure boot off i would love to know how. However, that will not stop our decision to replace with a different manufacturer. Thank you all!

    • #19196

      Hi Stephen,

      Thank you for your feedback and we understand your frustration however please understand that the issues have stemmed from changes in the operating system (Win 10 1903 or above) that could not be foreseen when the ActivBoards were made.  The functionality of the driver or the ActivBoard has not changed in over 10 years and continues to work with other operating systems.

      A fix for the blue screen errors was provided via the HID firmware, however with this, we appreciate that the ActivBoards that are powered externally via the amplifier currently have to have the amp turned off prior to the connection, and then turning the amp back on will establish a connection in ActivManager, which is different to how the ActivBoard has previously been used over the years.

      Our product teams are looking in to this and we are following this closely however we do not have a current update for this currently.

      We will update in due course once we have an update.

      Kind regards,
      Adam

      Promethean Support

       

       

    • #19235
      Adam VeatchAdam Veatch
      Participant

      If any feedback from the developers could be shared, I feel like it would alleviate some of the frustration. We’re now 4 months in since this issue was first raised and to our knowledge, Promethean’s developers haven’t identified what is causing the issue. Even a simple message of, “We’ve identified the root cause and are working towards a firmware/driver update that can resolve it,” would go a long way. Yes, these boards are old and no one could have foreseen Microsoft changing the OS so drastically, and yes, these things take time. But you’ve informed your customer base that a fix is incoming, the issue is incredibly disruptive, and we’ve seen how long it took to get an update the last time. 1903 was out before Promethean was even aware an issue had popped up. By that point, 1903 had been available in the Fast Ring for months. Your QA folks should be testing against the Fast Ring.

    • #19254
      stechgirlstechgirl
      Participant

      I agree with Adam that more than we are working on it would be nice.  Especially with how much time has passed.

    • #19257

      Hi both,

      I do not have any updates to provide on this issue as of yet.

      As soon as we do hear any updates, rest assured, I will let you know.

      Kind regards,

      Adam

      Promethean Support

    • #19306

      Hi All,

      Our product and development teams have been investigating the issue whereby you get no connection to an AB300 when the amplifier is on, and a computer or laptop is then connected or powered up.

      We are pleased to let you know that we have now released a new build of the firmware that resolves this problem.

      For ActivBoards that are already on firmware version v8.12 build 2 (Checked through ActivManager):
      The update can only be carried out ‘locally’ using the instructions provided in support article:

      1038


      Using this link to access the new firmware:
      http://www.activsoftware.co.uk/update/Driver/firmware/ab300/ac3-v812-4-hid.bin

      If you have ActivBoards that are on a earlier firmware version than v8.12 build 2 (Checked through ActivManager), these ActivBoards will be able to be updated following the instructions in the below article:

      1779

      Please note, the changes made on our update server can take time to propagate around the world, so you may not be offered the new firmware file just yet.

      With this new firmware, with no computer or laptop connected to the ActivBoard and the amplifier turned on, the ActivBoard flame LED will now flash red periodically instead of being solid red.
      The ‘wireless’ connection method is disabled for this firmware, and so should only be used on ActivBoards that are connected via a USB cable.

      If you have any questions around this, please do not hesitate to let us know.

      Thank you

    • #29593
      stechgirlstechgirl
      Participant

      Thanks Promethean for working on a fix for this issue.

      I have only tested a little since right after this fix was released COVID hit and teachers weren’t in classrooms using their boards.  I am going to be installing this fix on other boards and I just want to check that the method is still the same as the above steps?  I am not really seeing a change in your article about computers blue screening so I just want to make sure I have it correct.

Viewing 49 reply threads
  • You must be logged in to reply to this topic.