Interactive Whiteboards
Viewing 9 reply threads
  • Author
    Posts
    • #31608
      Carol SchmidtCarol Schmidt
      Participant

      We have Activboards in our school and when we returned from Thanksgiving break the pens will not respond on the boards.

    • #31612
      Adam VeatchAdam Veatch
      Participant

      We are experiencing the same issue with our 378Pros that have yet to be upgraded 8.12. Our setup is as follows:

      Windows 10 1809

      ActivDriver 5.18.19 x64

      ActivInspire 2.19

      Firmware is 8.04

       

      ActivManager takes a long time to come up, usually around 60 seconds. Even on NVMe drives. Board is detected, but not able to be used. We’ve attempted to upgrade the firmware, to no avail. The board refuses to upgrade, throwing up Upgrade Failed errors when trying both the file option and the internet option.

    • #31632
      James WaltenbaughJames Waltenbaugh
      Participant

      I’ve been dealing with this issue for the past week. While not everyone is affected, it has kept me busy. It seems to primarily affect our ActivBoard 300 Standard Series and this problem happens on computers running Windows 7 or any version of Windows 10. Here is what I did to fix it…

      My “Clean Computer”:
      For starters, you cannot update the board firmware using a computer experiencing this problem. I first started using my own laptop, but eventually, it stopped working and had to find a new laptop with a clean install of Windows 10 and used that to update the firmware. I installed ActivDriver_5_18_19_x64.exe on this new laptop and nothing else. This is my “Clean Computer” I used it to update countless Boards. My “Clean Computer” is not joined to our Active Directory Domain; might be important to know.

      Steps:

      1. Unplug USB cable that connects the affected Board and PC.
      2. Download and install ActivDriver_5_18_19_x64.exe on the affected PC.
        You might have to first uninstall the old drivers if you run into problems.
        Reboot when prompted.
      3. Connect your “Clean Computer” to the affected Board.
      4. Open ActivManager on your “Clean Computer” and install the latest Firmware.
        Here is additional info if needed. https://support.prometheanworld.com/article/1038/
      5. Once the Firmware is updated successfully, the flame will flash green. I usually try an ActivPen to see if it works.
      6. You can unplug the “Clean Computer” from the affected Board.
      7. Connect the affected Board and PC back together. Windows will see the board like it’s a new device and will install the needed drivers automatically. This can take a few minutes.
      8. Once ActivManager sees the Board, you can Calibrate the Board. The ability to launch calibration by hovering your ActivPen over the flame LED will be disabled.

      Important/What can go wrong:
      Both Drivers and Firmware must be updated! Failure to do both will only cause more problems.
      Updating only the drivers will fix the problem temporarily, but the board will eventually stop working again.
      Updating only the Board Firmware without updating the drivers will cause the Board to not be recognized properly by Windows and for me, caused a Stop Error on the affected PC.

      Conclusion:
      I’ll admit this is quite a task to fix these Boards. I still don’t know what caused all of our Boards to stop working, but updating the Drivers and Firmware has been fixing the issue so far. I suspect an OS or Security Update but have no proof. Hope this helps you fix your Boards.

    • #31675
      Karen PrometheanKaren Promethean
      Moderator

      Hello James,

      We do advise updating the ActivBoard 300 78 inch board’s firmware to the latest non-HID firmware (8.10) per the instructions listed in the following article on our support portal:  https://support.prometheanworld.com/article/1038/

      You will need to restart the computer after the update and reset the board per the following article on our support portal:  https://support.prometheanworld.com/article/1287/

      If the issue persists then please update to 8.12 HID firmware through the ActivManager using the internet source instead of a file.

      Also, using the latest ActivDriver (5.18.19) is recommended.  It can be updated here:  https://support.prometheanworld.com/product/-activdriver-/

      Please let us know if you have any questions – we are happy to assist.

      Kind Regards,

      Karen

    • #31732
      Adam VeatchAdam Veatch
      Participant

      Machines experiencing this issue that cannot upgrade firmware have successfully been upgraded by downgrading the driver to 5.18.12 first, upgrading firmware to 8.10, upgrading firmware again to 8.12, then upgrading the driver back to 5.18.19.

    • #31763
      Craig PrometheanCraig Promethean
      Moderator

      Hello Adam,

      That’s great, thank you for letting us know.

      Please do not hesitate to contact us if you need any further support.

      Kind regards,

      Craig

    • #32963
      John O'MahonyJohn O’Mahony
      Participant

      Hello,

      I have followed the guidelines outlined by Karen to try to update from firmware version 8.04 to version 8.10 on a Promethean AB378, using just a 2m USB cable that I successfully used to update firmware on a number of other boards over the last 12-18 months as the laptops connected to the boards updated their versions of Windows 10. The laptop connected is a brand new DynaBook with Win 10 20H2 ActivDriver 5.18.19. Update fails each time I have tried, I have tried resetting the board, downloading firmware again and restarting the laptop to no avail. Updating  from 8.04 to 8.12 HID as suggested by Karen also fails.
      Similar laptops (Win 10 20h2 and ActivDriver 5.18.19 are working on other AB 378 with firmware 8.12  HID but firmware was updated some time ago. This particular board hadn’t been updated as a much older laptop was connected with an older version of Win10.
      I would like to try using ActivDriver 5.18.12 as has worked for Adam Veatch a number of times if someone here can point me in the direction of the download or indeed any other suggestions that Promethean or other participants can point me to.

      Thanks in anticipation.

      John.

    • #32992
      Paul PrometheanPaul Promethean
      Moderator

      Hi John,

      I have sent you an email to your registered address on this matter.

      Kind regards,

      Paul

      Promethean Technical Support

    • #33041
      John O'MahonyJohn O’Mahony
      Participant

      Hi Paul, Adam and all,

      The solution of rolling back ActivDriver as shared by Adam here to update firmware from version 8.04 to 8.10 initially before installing latest HID version has worked for me too. Thanks Paul, for sending the link to the ActivDriver version 5.18.12 to me.

      Hope Adam’s solution works for others too.

      Thanks everyone,

      John.

    • #33064
      Slim PrometheanSlim Promethean
      Moderator

      Hi John,

      Thank you for letting us know.

      We’re happy to read that the issue is now fixed.

      Should you need any further assistance, please do not hesitate to let us know.

      Kind regards,
      Slim

      Promethean Technical Support

Viewing 9 reply threads
  • You must be logged in to reply to this topic.