Projectors
Viewing 2 reply threads
  • Author
    Posts
    • #35480
      Liam BellLiam Bell
      Participant

      Hello,

      I’ve got a PRM-20AV1(S) model that I’ve been nursing to keep alive for some months now. It’s now no longer powering on except very occasionally. If I plug it in and the LED lights, sometimes I can switch it on successfully. Other times, the LEDs do not light and there is a very loud coil whine coming from the unit.

       

      Is there any chance of being able to repair this, or am I doomed to splash cash to replace it?

       

      Kind regards,

       

      Liam

    • #35518

      Hello Liam,

      Thank you for your post.

      Kindly confirm, do you notice any LED sequences when the projector boots up? Does it possibly sound like the fan is whats causing the noise? After we confirm the answers to these questions, we may be able to follow up with you privately to explore additional options.

      Kind regards,

      Jordan

      Promethean Technical Support

      • #35519
        Liam BellLiam Bell
        Participant

        Hi Jordan,

         

        No LED sequences and absolutely not the fan that’s making the noise.

         

        Thanks,

         

        Liam

    • #35537

      Hello Liam,

      Thank you for your post to our Forum.

      Due to the nature of this issue, we are going to contact you directly via e-mail with specific steps for repair.

      Kind regards,

      Jordan

      Promethean Technical Support

Viewing 2 reply threads
  • The topic ‘PRM-20 Intermittent Power’ is closed to new replies.