What is ActivInspire?
Viewing 4 reply threads
  • Author
    Posts
    • #1265
      Mike HeddersonMike Hedderson
      Participant

      Will ActivInspire be supported on 64-bit installations in the future? The issue is Google is removing support for 32-bit installations of Linux, so that will force us to migrate to 64-bit. The only reason I have continued using 32-bit is to support ActivInspire. I have tried various ways of getting ActivInspire installed on 64-bit, but it always errors out at some point.

      Supporting 64-bit would be most appreciated.

    • #6474
      Anonymous
      Inactive

      The ActivInspire Software is currently only compatible with 32-bit versions of Ubuntu 12.04. While you may be able to install that software on other flavors of Linux, we cannot guarantee full functionality of the software and may recommend that any issues be tested in a compatible operating system during the course of troubleshooting.

      We will raise 64-bit compatibility with Linux operating systems with our teams here so that feature can be considered for inclusion in a future release of the ActivInspire software. Any announcements to this effect will be posted to this community and to our Support Page once that release is available.

      However, if you are still able to use Google Chrome in Linux, you should have the ability to utilize our ClassFlow application as a web-based lesson creation and presentation tool. More information regarding that application can be found on the ClassFlow website.

      (Support Case 00620077)

    • #6475
      Anonymous
      Inactive

      Hi Mike,

      Thank you for your feedback, we really appreciate it. We’ve raised this Enhance Request for our developers’ consideration. If you have any other comments moving forward, please let us know.

      Kind Regards,

      Jose Corona
      Promethean Escalations

    • #6476
      Anonymous
      Inactive

      Hello,

      I succesfully installed and used Activinspire in 64bit systems several times, although it’s 32bit software. This is my recipe. If you have already installed it and get an error, go to 4.

      I must warn you that:
      – English is not my mother language, I’m translating here, so I apologize in advance for the weird language.
      – I use Mint 17.3, based on Ubuntu 14.04. I’m not sure that this is valid for newer versions of Ubuntu or Mint. See 1.
      – For non-experts: you need a superuser account (i.e. be able to install sw), and some use of the terminal. You can just copy the indented lines from this message (without the comments), and paste them in the terminal with Ctrl+Shift+V

      1. Open Synaptic, look for ‘Repositories’ in the menus, and add this line:    deb http://activsoftware.co.uk/linux/repos/ubuntu trusty oss non-oss

      The third word from the right (trusty) is the Ubuntu edition codename. I’m using Mint 17.3, based on Ubuntu 14.04, codenamed ‘trusty’. All Mint 17.X editions are based on it. If you are using a newer Ubuntu or Mint, write its codename instead. For Mint 18.X and Ubuntu 16.04 or later, I would try with ‘xenial’. But if it doesn’t work, go with ‘trusty’.

      2. Add the Promethean authentication key.

      Open a terminal (Ctrl+T) and write this, pressing <Enter> at the end of every line.

          wget http://www.activsoftware.co.uk/linux/repos/Promethean.asc        (you are downloading the key)
          sudo apt-key add Promethean.asc                                                     (adding the key)

      3. Download and install the software

      You can do this using the terminal or with Synaptic

          sudo apt-get update                             (or press ‘Refresh’ in Synaptic, you are updating the package list)

      There are two software components: the editor/presenter and the drivers. You may not need both:
      – If your computer will be connected to a Promethean whiteboard, and you want to manage it (use the magnetic pen, and so on), then you need both components.
      – If you don’t have a Promethean whiteboard, or this is your home computer and you just want to prepare your presentations, then you will only use the editor, you don’t need the drivers.

      In the first case, download this: activ-meta-xx (replace -xx with your language code: -en for english, -de for deutsch, -es for spanish… Synaptic will show you all the languages). This will download the six needed packages: activinspire, activaid, activinspire-help-xx, activresources-core-xx, activtools, activdriver. Do it with Synaptic or use the terminal instead:

          sudo apt-get install activ-meta-en                               (-en would be for English)

      In the second case, you need only the first four packages: activinspire, activaid, activinspire-help-xx, activresources-core-xx. Use Synaptic to download them or do it with the terminal:

          sudo apt-get install activinspire activaid activinspire-help-en activresources-core-en                    (-en for English)

      4. Try to open Activinspire. If your system is 64bit, you will get an error. You need to do this:

      With the terminal, make a directory called ‘lib32’ at /usr/local:

          sudo mkdir /usr/local/lib32

      Make a symbolic link:

          sudo ln -s /usr/lib/i386-linux-gnu/libjpeg.so.8 /usr/local/lib32/libjpeg.so.62

      Activinspire needs a library called libjpeg.so.62 to be present at the lib32 directory, but apparently doesn’t use it. So we can redirect it to a different library (libjpeg.so.8) without consequences.

      And you’re done! Hope this helps.

    • #6477
      Anonymous
      Inactive

      Hello again,

      I just did my first install on a Mint 18.3 laptop, and things have changed a bit.

      – The deb line works with ‘xenial’ instead of ‘trusty’

      – The activ-meta-xx package doesn’t include the whiteboard drivers and controls now. If you need them check this page:

          https://community.prometheanworld.com/en/discussion/7001300/installing-the-activdriver-on-linux

      – The 32bit error is solved

Viewing 4 reply threads
  • You must be logged in to reply to this topic.