Solutions Logicielles
Vous lisez 14 fils de discussion
  • Auteur
    Messages
    • #16143
      Christophe COQUETChristophe COQUET
      Participant

      Bonjour,

      Je suis utilisateur dans ma classe d’un TBI ActivBoard relié à un ordinateur sous Ubuntu 16.04.

      J’espère depuis un moment pouvoir mettre à jour mon ordi vers Ubuntu 18.04 au moins.

      Jusqu’à présent, j’étais coincé par les pilotes et utilitaires de mon TBI.

      Or je lis sur votre site que la mise à jour ActivDriver 5.18.11 prend en charge Ubuntu 18.04.

      J’en suis heureux mais seuls des liens de téléchargement pour Windows et Mac OS sont disponibles.

      Je vous remercie donc de publier les liens vers les dépôts, vers la clé, vers les paquets deb éventuellement…

      Par ailleurs, ces pilotes sont-ils compatibles avec le noyau 4.15 uniquement ou également avec les noyaux ultérieurs ? Est-il possible de les utiliser sous la version la plus récente d’Ubuntu, à savoir la 19.04 ?

      Merci d’avance,

      Christophe Coquet

    • #16146
      Adam H PrometheanAdam H Promethean
      Senior Moderator

      Bonjour Christophe,

      Merci pour votre post. Nous avons quelques fichiers d’installation de l’ActivDriver pour Ubuntu 18.04 qui n’a pas besoin d’un noyau spécifique. Pour l’instant, nous n’avons pas d’autre façon d’installer le pilote avec les dépôts etc.

      Nous vous conseillons tout d’abord de mettre à jour Ubuntu et puis de déconnectez le câble USB de votre tableau. Après, merci d’installer les trois fichiers dans l’ordre alphabétique:

      32-bits
      ActivAid – https://promethean.box.com/s/kwce84alyuu2z8t74d7ziticvlyij4sg
      ActivDriver – https://promethean.box.com/s/6s5nkdtite7g52kreeek5zyufbp3ee5h
      ActivTools – https://promethean.box.com/s/38uzlccidx3hgkt7i779vb6tetqur6bc

      64-bit
      ActivAid – https://promethean.box.com/s/s0qvdws8qqwrrtnw527bz64rb36kkg5g
      ActivDriver – https://promethean.box.com/s/66gzx0de13r3w7kfp2eb56e7fp6mv26t
      ActivTools – https://promethean.box.com/s/jj9hk1ahh0xxb7kxgf86mb1nj0734f4n

      Cordialement,
      Adam

      Le Support Technique Promethean
      https://support.prometheanworld.com/fr/

       

    • #16147
      Christophe COQUETChristophe COQUET
      Participant

      Merci Adam pour votre réponse rapide.

      Qu’en est-il d’ActivInspire ?

      Y a-t-il une version installable sous Ubuntu 18.04 ?

      Christophe

    • #16148
      Adam H PrometheanAdam H Promethean
      Senior Moderator

      Bonjour Christophe,

      Merci pour votre réponse. Nous n’avons pas encore une version d’ActivInspire pour 18.04 mais nous pouvons passer votre demande en interne à notre équipe de développement.

      Cordialement,
      Adam

      Le Support Technique Promethean
      https://support.prometheanworld.com/fr/

       

    • #16152
      Christophe COQUETChristophe COQUET
      Participant

      Merci effectivement de passer cette demande.

      Avec un TBI ActivBoard sans ActivInspire, on y perd beaucoup !

      Christophe

    • #16156
      Adam H PrometheanAdam H Promethean
      Senior Moderator

      Bonjour Christophe,

      Merci pour votre post et je comprends votre point. Comme le pilote ActivDriver est nécessaire pour faire fonctionner le tableau, il a été développé en priorité. Il y a aussi des utilisateurs qui n’utilise pas ActivInspire par exemple mais a besoin de l’interaction.

      Si vous souhaitez utiliser les deux programmes, la meilleure solution serait d’utiliser la version 16.04 Ubuntu jusqu’à la sortie d’ActivInspire pour 18.04.

      Cordialement,
      Adam

      Le Support Technique Promethean
      https://support.prometheanworld.com/fr/

    • #16235
      Christophe COQUETChristophe COQUET
      Participant

      Pour ceux que ça intéresse, j’ai réussi à faire marcher mon TBI sous Ubuntu 19.04 (Xubuntu en fait).

      Pour cela, installer les paquets listés dans le post #16146, dans l’ordre indiqué.

      Faire un “sudo apt-get install -f” après chaque paquet pour installer les dépendances manquantes.

      De plus, pour ActivTools, il faut corriger la dépendance envers le paquet “libssl1.0.0” en remplaçant par “libssl1.1”. Pour cela, faire “sudo gedit /var/lib/dpkg/status” et faire “rechercher et remplacer”.

      Enfin, il faut downgrader le noyau à la version 4.19 (je n’ai pas encore essayé la version 4.20, en tout cas en version 5.0 ça ne marche pas).

      Christophe

    • #16236
      Yann BYann B
      Senior Moderator

      Bonjour Christophe,

      Merci pour votre post et pour avoir partagé votre méthode pour Ubuntu 19.04.

      Si cela fonctionne, tant mieux.

      Pour information, Promethean ne supporte que les versions LTS d’Ubuntu, dont la dernière est 18.04.

      Ubuntu 19.04 et cette méthode ne seront donc pas soutenus par Promethean.

      Yann
      Le Support Technique Promethean.

    • #30739
      Didier SEVERINDidier SEVERIN
      Participant

      Bonjour,

      les établissements scolaires (dont le mien) se sont majoritairement dotés en solution TBI Promethean (Activboard). Nous avons actuellement 13 Activboard au collège dans lequel je travaille et, conformément aux préconisations ministérielles nous sommes passés à Ubuntu 18.04.5 LTS en remplacement de Windows 7 depuis le mois de juillet.

      Malheureusement, que ce soit en suivant la procédure : https://www1.support.prometheanworld.com/fr/article/?kb=1623 ou celle décrite plus haut, les drivers ne se compilent pas… Le downgrade vers un kernel 4 n’est évidemment pas envisageable dans une structure où de nombreuses données sensibles circulent sur les ordinateurs…

      Driver location: /lib/modules/5.4.0-48-generic/kernel/drivers/input/tablet
      Promethean: Copying driver module in kernel.
      rmmod: ERROR: Module promethean is not currently loaded
      insmod /lib/modules/5.4.0-48-generic/kernel/drivers/input/tablet/promethean.ko
      modprobe: ERROR: could not insert ‘promethean’: Exec format error
      Promethean: No driver found for the current kernel 5.4.0-48-generic. The driver needs to be rebuilt.
      Promethean: This requires make, gcc and the kernel headers / kernel source packages.
      Promethean: Building Promethean activdriver…
      make -C /lib/modules/5.4.0-48-generic/build SUBDIRS=”/usr/src/promethean/kernel” clean
      make[1] : on entre dans le répertoire « /usr/src/linux-headers-5.4.0-48-generic »
      fs/aufs/Makefile:3: fs/aufs/magic.mk: Aucun fichier ou dossier de ce type
      make[3]: *** Aucune règle pour fabriquer la cible « fs/aufs/magic.mk ». Arrêt.
      make[2]: *** [scripts/Makefile.clean:67 : fs/aufs] Erreur 2
      make[1]: *** [Makefile:1741 : _clean_fs] Erreur 2
      make[1] : on quitte le répertoire « /usr/src/linux-headers-5.4.0-48-generic »
      make: *** [Makefile:9 : clean] Erreur 2
      Promethean: Error building driver.

      Je vous remercie de bien vouloir réaliser une mise à jour d’activdriver prenant en compte le kernel 5.4.

      Pour l’Académie de la Réunion, Didier SEVERIN, Interlocuteur Académique au Numérique et Responsable des Ressources et Usages Pédagogiques du Numérique

    • #30764
      Thibaut PrometheanThibaut Promethean
      Modérateur/modératrice

      Bonjour Didier,

      Merci pour votre publication.

      Nous allons vous contacter directement par email pour ajouter votre demande de compilation pour le kernel 5.4

       

      Restant à votre disposition, veuillez accepter nos sincères salutations.

      Cordialement,

      Thibaut

       

      Le Support Technique Promethean

      https://support.prometheanworld.com/fr/

       

    • #30820
      Serge MacasdarSerge Macasdar
      Participant

      Bonjour à tous,

       

      je suis responsable numérique de mon établissement, qui compte 24 TBI Promethean. Nous sommes en train de basculer sur Ubuntu 18.04 et l’absence de solution technique claire et complète quand à l’utilisation de ces TBI sous Ubuntu est un problème qui commence à devenir bloquant.

      Nous sommes donc dans l’attente de cette solution.

       

      Cordialement,

       

      Serge Macasdar

    • #30825
      Didier SEVERINDidier SEVERIN
      Participant

      Bonjour, j’ai réussi à faire fonctionner activInspire sur de nombreuses flavours d’Ubuntu (Xubuntu, Lubuntu, Kubuntu, UbuntuDDE) en version 18.04 et 20.04 ainsi que sur LinuxMint 18.04 / 20.04 et elementaryOS.

      Pour cela :

      # Rendre ActivInspire fonctionnel
      wget http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu60_60.2-3ubuntu3.1_amd64.deb
      sudo dpkg -i libicu60_60.2-3ubuntu3.1_amd64.deb
      sudo apt-get install gsettings-ubuntu-schemas

      J’attends toujours une mise à jour d’activdriver pour Ubuntu 18.04 (et surtout 20.04) avec prise en charge des kernel 5.x

      Pour l’Académie de la Réunion, Didier SEVERIN, Interlocuteur Académique au Numérique et Responsable des Ressources et Usages Pédagogiques du Numérique

    • #30837
      Thibaut PrometheanThibaut Promethean
      Modérateur/modératrice

      Bonjour Serge,

      Merci pour votre publication.

      Comme l’a indiqué Didier dans sa réponse, merci d’essayer avec sa solution.

      En effet, nous avons plusieurs demandes en cours pour qu’ActivDriver et ActivInspire soit prise en charge des kernel 5.x

       

      Nous informerons bien sûr les utilisateurs une fois que cela est disponible sur ce forum.

      Cordialement,

      Thibaut

       

      Le Support Technique Promethean

      https://support.prometheanworld.com/fr/

    • #30847
      Didier SEVERINDidier SEVERIN
      Participant

      Bonsoir à tous,

      pour ceux qui souhaitent gagner du temps dans les commandes voici le script que j’ai utilisé dans mon établissement pour rendre ActivTools et ActivInspire fonctionnels sur les Ubuntu 18.04 / 20.04 et les LinuxMint de mon établissement.

      Cliquer ici pour télécharer installActivInspire.sh

      @ bientôt

    • #30849
      Didier SEVERINDidier SEVERIN
      Participant

      Bonsoir à tous,

      pour ceux qui souhaitent gagner du temps dans les commandes voici le script que j’ai utilisé dans mon établissement pour rendre ActivTools et ActivInspire fonctionnels sur les Ubuntu 18.04 / 20.04 et les LinuxMint de mon établissement.

      Cliquer ici pour télécharer installActivInspire.sh

      Toutefois comme beaucoup, je reste dans l’attente d’une mise à jour d’activdriver pour Ubuntu 18.04 (et surtout 20.04) avec prise en charge des kernel 5.x

      @ bientôt

Vous lisez 14 fils de discussion
  • Vous devez être connecté pour répondre à ce sujet.